Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231735 - It's not possible to set different annotation highlight for different profile
It's not possible to set different annotation highlight for different profile
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Options
7.4
All All
: P3 with 1 vote (vote)
: 8.0
Assigned To: Milutin Kristofic
issues@editor
:
: 236873 (view as bug list)
Depends on:
Blocks: 231617 233508
  Show dependency treegraph
 
Reported: 2013-06-24 16:17 UTC by Martin Entlicher
Modified: 2013-10-09 12:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Implementation for Annotations. (37.93 KB, patch)
2013-09-17 14:16 UTC, Milutin Kristofic
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2013-06-24 16:17:21 UTC
I was not successful in setting a different annotation background colors for different profiles. It looks like it's not possible.

Steps to reproduce:
1. Go to Tools/Options -> Fonts & Colors, select Annotations tab
2. Select Breakpoint category and see the default background [252, 157, 159]
3. Change the profile to Norway Today and select Breakpoint again.
4. Change background to Dark Gray.
5. Switch between NetBeans and Norway Today profiles and verify that it shows the expected background colors for Breakpoint.
6. Press OK while Norway Today is selected. The colors in all editors are adjusted as expected.
7. Go to Tools/Options -> Fonts & Colors, select Annotations tab and change the profile back to NetBeans.
8. The Breakpoint category now has the Dark Grey background. This is unexpected, we just changed the background in Norway Today profile.
9. Press OK, the all breakpoints are dark gray in all editors.
10. I'm not able to revert to the original color. "Restore" on the NetBeans profile does nothing. It looks like the only solution is to delete config/Editors/AnnotationTypes folder.
Comment 1 Milutin Kristofic 2013-09-17 14:16:36 UTC
Created attachment 140174 [details]
Implementation for Annotations.

I created a similar solution as highlighting coloring has for profile saving, but I wrapped this by AnnotationType. I left both ways, but profile will override annotation type colorings.
Comment 2 Milutin Kristofic 2013-10-02 13:58:35 UTC
http://hg.netbeans.org/jet-main/rev/502619d62dcb
Comment 3 Quality Engineering 2013-10-04 01:32:46 UTC
Integrated into 'main-silver', will be available in build *201310040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/502619d62dcb
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #231735 - It's not possible to set different annotation highlight for different profile
Comment 4 Milutin Kristofic 2013-10-09 12:30:11 UTC
*** Bug 236873 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo