Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231617 - [Dark Theme] Source code not readable during debugging
[Dark Theme] Source code not readable during debugging
Status: RESOLVED INCOMPLETE
Product: debugger
Classification: Unclassified
Component: Code
7.4
All All
: P3 (vote)
: 8.0
Assigned To: Jan Peska
issues@debugger
: NO74
: 233166 (view as bug list)
Depends on: 231735
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 09:53 UTC by Tomas Mysik
Modified: 2017-03-17 16:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (40.37 KB, image/png)
2013-06-21 09:53 UTC, Tomas Mysik
Details
Shows the color settings in IntelliJ IDEA darcula theme (69.25 KB, image/png)
2013-09-10 23:13 UTC, markiewb
Details
example patch (3.43 KB, patch)
2014-02-03 16:56 UTC, Milutin Kristofic
Details | Diff
Shows the issue - still in 201402110001 build (280.62 KB, image/png)
2014-02-11 14:04 UTC, markiewb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2013-06-21 09:53:33 UTC
Created attachment 136126 [details]
screenshot

Have a look at the screenshot.

Thanks.

Product Version: NetBeans IDE 7.4 Beta (Build 20130617-a607f6dd7537)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Linux version 3.8.0-25-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Martin Entlicher 2013-06-21 09:58:35 UTC
The breakpoint and current line annotations need to be darker.
Comment 2 Tomas Mysik 2013-06-24 13:14:16 UTC
I changed it to 84, 112, 71 and it is much better now. Thanks for the hint ;)
Comment 3 Tomas Mysik 2013-06-24 13:20:10 UTC
BTW I have changed color for "Program Counter and a Breakpoint" but it does not work (the color is still same as before although new color is set in IDE Options).

Thanks.
Comment 4 Tomas Mysik 2013-06-24 13:25:11 UTC
IDE restart helped...
Comment 5 Martin Entlicher 2013-06-24 16:18:48 UTC
It looks like it's not possible to fix this before issue #231735 is fixed.
Comment 6 markiewb 2013-07-22 15:16:00 UTC
*** Bug 233166 has been marked as a duplicate of this bug. ***
Comment 7 Marian Mirilovic 2013-08-23 13:53:20 UTC
Dark themes were moved to the NetBeans Update Center for NB 7.4
Comment 8 markiewb 2013-09-10 23:13:21 UTC
Created attachment 139901 [details]
Shows the color settings in IntelliJ IDEA darcula theme

You could use the same colors as IntelliJ IDEA darcula theme uses:

Breakpoint line: rgb(58 35 35) Dark red
Execution line: rgb(45 96 153) Blue

See screenshot

I know in NetBeans you can define nearly every combination of breakpoint and state like "broken line breakpoint with current execution point". This is overkill IMHO. Breakpoint line should be "dark red". Combinations which include the current execution line should be "blue". Nothing more. 

@Martin: What do you think?
Comment 9 Martin Entlicher 2013-09-11 06:09:07 UTC
Thanks for the hints, but unfortunately I can not do anything in this area, until issue #231735 is fixed.
Comment 10 markiewb 2013-09-12 20:08:54 UTC
*** Bug 205410 has been marked as a duplicate of this bug. ***
Comment 11 lforet 2014-01-10 15:12:39 UTC
The dark theme will be soon very cool and complete. IMHO, I just miss this one.

Regards.
Comment 12 Jan Peska 2014-02-03 13:48:00 UTC
it seems that fix of issue #231735 does not allow to add a default value for different editor profiles (in this case Norway Today).

I've added new xml file into to the defaults module (BlueTheme-annotations.xml) with new color value of the breakpoint but the default value is unchanged (tried with empty userdir).

I'm reassigning the issue to Editor. Mito, can you please take a look?

Thanks
Comment 13 Milutin Kristofic 2014-02-03 16:55:02 UTC
I forgot to tell you that you need to register file to layer.xml.
Comment 14 Milutin Kristofic 2014-02-03 16:56:42 UTC
Created attachment 144743 [details]
example patch

Here is an example, and it works.
Comment 15 Jan Peska 2014-02-04 16:47:31 UTC
fix: http://hg.netbeans.org/core-main/rev/91268b4c3651
Comment 16 Quality Engineering 2014-02-07 02:38:08 UTC
Integrated into 'main-silver', will be available in build *201402070001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/91268b4c3651
User: Jan Peska <JPESKA@netbeans.org>
Log: Issue #231617 - [Dark Theme] Source code not readable during debugging
Adjust background colors for Norway Today
Comment 17 markiewb 2014-02-11 14:04:13 UTC
(In reply to Quality Engineering from comment #16)
> Integrated into 'main-silver', will be available in build *201402070001* on
> http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
> 
> Changeset: http://hg.netbeans.org/main-silver/rev/91268b4c3651
> User: Jan Peska <JPESKA@netbeans.org>
> Log: Issue #231617 - [Dark Theme] Source code not readable during debugging
> Adjust background colors for Norway Today

Reopen. Disabled breakpoints are still white on gray background and white on green background. See screenshot

Product Version: NetBeans IDE Dev (Build 201402110001)
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 7 version 6.1 running on amd64; Cp1252; de_DE (nb)
Comment 18 markiewb 2014-02-11 14:04:51 UTC
Created attachment 145039 [details]
Shows the issue - still in 201402110001 build
Comment 19 Jan Peska 2014-02-12 12:40:09 UTC
fix: http://hg.netbeans.org/core-main/rev/bb5883cc54f9

I've changed also color for disabled breakpoint but I've noticed with new userdir all changed colors are ignored by editor - in options they are set to the right values but editor ignores them and uses the default ones. To workaround this issue you have to click "Restore" button and reopen editor window. I'll file new bug to editor team since the color setup is fixed.
Comment 20 venkatramakkineni 2014-08-03 07:13:41 UTC
Jan,

Is there another bug out there for this issue ? Could you please attach it here ?

(In reply to Jan Peska from comment #19)
> fix: http://hg.netbeans.org/core-main/rev/bb5883cc54f9
> 
> I've changed also color for disabled breakpoint but I've noticed with new
> userdir all changed colors are ignored by editor - in options they are set
> to the right values but editor ignores them and uses the default ones. To
> workaround this issue you have to click "Restore" button and reopen editor
> window. I'll file new bug to editor team since the color setup is fixed.
Comment 22 JumonjiNinja 2017-03-17 16:47:41 UTC
This bug has resurfaced in 8.2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo