Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231605 - Git repository cannot commit submodule's updated version, to track the new version
Git repository cannot commit submodule's updated version, to track the new ve...
Status: RESOLVED DUPLICATE of bug 207067
Product: versioncontrol
Classification: Unclassified
Component: Git
7.3.1
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-21 07:43 UTC by naitsirch
Modified: 2013-06-21 09:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of the differences between cmd and Netbeans submodule handling (161.70 KB, image/png)
2013-06-21 07:43 UTC, naitsirch
Details
Screenshot of the differences between cmd and Netbeans submodule handling (161.70 KB, image/png)
2013-06-21 07:48 UTC, naitsirch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description naitsirch 2013-06-21 07:43:02 UTC
Created attachment 136110 [details]
Screenshot of the differences between cmd and Netbeans submodule handling

Hi.
I am working with a git repository which contains the symfony framework. One of the bundles (the "FutarBundle") is organized as a submodule.

Please look at the attached screenshot for better understanding.

- I have done some changes in the submodule and committed these changes
- Netbenas shows the correct status of the committed files. They are not marked as changed any more. That's correct (so it's different case as in #207067)
- But in Netbenas it is not possible to commit the new version to the main repository to tell the repository to track the new version (see http://stackoverflow.com/a/5542964/1119601)
- In the command line git shows the submodule as "modified ... (new commits)"

It would be really nice if this could be possible in NB.

Thanks so far!
Comment 1 naitsirch 2013-06-21 07:48:53 UTC
Created attachment 136111 [details]
Screenshot of the differences between cmd and Netbeans submodule handling
Comment 2 Ondrej Vrabec 2013-06-21 09:17:45 UTC
it must be fixed as part of bug #207067

*** This bug has been marked as a duplicate of bug 207067 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo