Bug 231255 - Auto focus in navigator window
Auto focus in navigator window
Status: RESOLVED INCOMPLETE
Product: java
Classification: Unclassified
Component: Navigation
7.4
PC Windows 7
: P3 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 07:46 UTC by nimmr
Modified: 2013-06-18 12:27 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nimmr 2013-06-14 07:46:02 UTC
Hi

I have a little request that would make a great feature, even more great. 

I use your navigator window alot for looking up my methods/properties/etc, and I especially use your search feature inside that window. 

Everything here works as it should, except one small thing. 

I have the navigator window on a minimized state, and the press a shortcut to bring it up. At this point, I would like to be able to start typing, and it would use the search feature for the window, but the window dosn't have focus yet, I have to click it with my mouse. 

I would really like if you made the window autofocus when you use a shortcut key to show the window. 

I know it's a small thing, but it would mean alot to me.

Thanks in advance
Comment 1 Stanislav Aubrecht 2013-06-17 07:44:46 UTC
Works for me in

Product Version: NetBeans IDE Dev (Build 20130614-9cce594f51d9)
Java: 1.7.0_15; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_15-b03
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)
Comment 2 nimmr 2013-06-18 12:19:01 UTC
I updated to 7.3.1, but for some reason, it wont start. I have to kill the process.


Oh well, back to 7.3, and I updated the plugins there, and now my version is:

Product Version: NetBeans IDE 7.3 (Build 201306052037)
Updates: NetBeans IDE is updated to version NetBeans 7.3 Patch 2
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)


It still dosnt work. Maybe it's just the dev build your running?
Comment 3 nimmr 2013-06-18 12:27:42 UTC
Are you sure you are testing with the navigator window minimized?

If it's not minimized it works one mine as well.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo