Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231160 - NullPointerException at org.netbeans.modules.java.hints.errors.CreateElementUtilities.computeMemberSelect
NullPointerException at org.netbeans.modules.java.hints.errors.CreateElementU...
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Hints
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Jan Lahoda
issues@java
EXCEPTIONS_REPORT
:
: 231353 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 15:37 UTC by Jiri Skrivanek
Modified: 2013-06-20 14:30 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.48 KB, text/plain)
2013-06-12 15:37 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2013-06-12 15:37:52 UTC
This bug was originally marked as duplicate of bug 111928, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE Dev (Build 201306112301)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.25-b01, Java(TM) SE Runtime Environment, 1.7.0_25-b14
OS: Windows 7

User Comments:
jskrivanek: Opened file in editor.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.java.hints.errors.CreateElementUtilities.computeMemberSelect(CreateElementUtilities.java:357)
   at org.netbeans.modules.java.hints.errors.CreateElementUtilities.resolveType(CreateElementUtilities.java:117)
   at org.netbeans.modules.java.hints.errors.CreateElement.analyze(CreateElement.java:304)
   at org.netbeans.modules.java.hints.errors.CreateElement.run(CreateElement.java:121)
   at org.netbeans.modules.java.hints.infrastructure.CreatorBasedLazyFixList.compute(CreatorBasedLazyFixList.java:147)
   at org.netbeans.modules.java.hints.infrastructure.LazyHintComputation.run(LazyHintComputation.java:112)
Comment 1 Jiri Skrivanek 2013-06-12 15:37:53 UTC
Created attachment 135706 [details]
stacktrace
Comment 2 Quality Engineering 2013-06-15 03:03:07 UTC
Integrated into 'main-golden', will be available in build *201306142301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/80d9df7bdb73
User: Jan Lahoda <jlahoda@netbeans.org>
Log: #231160: preventing NPE.
Comment 3 Jan Lahoda 2013-06-17 10:48:12 UTC
*** Bug 231353 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo