Bug 231040 - NullPointerException at com.sun.tools.javac.jvm.Code.typecode
NullPointerException at com.sun.tools.javac.jvm.Code.typecode
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 15:28 UTC by tnleeuw
Modified: 2015-09-17 11:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.04 KB, text/plain)
2013-06-10 15:28 UTC, tnleeuw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tnleeuw 2013-06-10 15:28:45 UTC
Build: NetBeans IDE Dev (Build 201306100004)
VM: Java HotSpot(TM) Client VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Windows Vista

User Comments:
tnleeuw: This happened after switching project groups, while background scanning of projects was underway. NetBeans was not in the foreground since I was doing something else during the wait.




Stacktrace: 
java.lang.NullPointerException
   at com.sun.tools.javac.jvm.Code.typecode(Code.java:229)
   at com.sun.tools.javac.jvm.Items.makeStackItem(Items.java:110)
   at com.sun.tools.javac.jvm.Gen.visitSelect(Gen.java:2287)
   at com.sun.tools.javac.tree.JCTree$JCFieldAccess.accept(JCTree.java:1886)
   at com.sun.tools.javac.jvm.Gen.genExpr(Gen.java:935)
   at com.sun.tools.javac.jvm.Gen.genArgs(Gen.java:954)
Comment 1 tnleeuw 2013-06-10 15:28:47 UTC
Created attachment 135595 [details]
stacktrace
Comment 2 Martin Balin 2015-09-17 11:22:11 UTC
Report from old NetBeans version. Due to code changes since it was reported likely not reproducible now. Feel free to reopen if happens in 8.0.2 or 8.1.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo