Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 230991 - Add ability to change current tracked remote branch
Add ability to change current tracked remote branch
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Git
7.3
PC Linux
: P3 with 1 vote (vote)
: 8.0
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 17:43 UTC by magnetox
Modified: 2013-10-04 01:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description magnetox 2013-06-09 17:43:10 UTC
There is no option to change the remote tracked branch of a local branch, so the "Push to upstream" options shows an error. The only workaround is to push the current branch to remote (via the long wizard), then create a new branch based on the remote one, and finally the "Push to upstream" option works as intended.

Steps to reproduce:
1) Create a new project
2) Initialize GIT
3) Push to a remote repository
4) Try to select the option "Push to upstream" and an error will pop: "No tracked remote branch specified for local <branch name>". There is no way to select the tracked remote branch.

What is expected:
Alternative A: In the error shown, there should be an option to select which locale remote will be set to be tracked.
Alternative B: In the Git Repository Browser, in the context menu of a local branch, there should be an option to set the tracked remote branch of that local branch.

About:
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.5.0-28-generic running on i386; UTF-8; en_US (nb)
Comment 1 Ondrej Vrabec 2013-10-02 15:39:32 UTC
fixing: Git Repository Browser -> select a local branch -> popup menu -> Setup Tracked Branch. Or a shortcut: Team -> Git -> Branch -> Set Tracked Branch just for the current branch

fix: http://hg.netbeans.org/core-main/rev/f9f9116999b5
Comment 2 Quality Engineering 2013-10-04 01:32:05 UTC
Integrated into 'main-silver', will be available in build *201310040001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/f9f9116999b5
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #230991 - Add ability to change current tracked remote branch


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo