Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 230915 - NoClassDefFoundError: org/openide/util/Enumerations$RNulls
NoClassDefFoundError: org/openide/util/Enumerations$RNulls
Status: RESOLVED DUPLICATE of bug 211962
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.3
All All
: P2 (vote)
: 7.3.1
Assigned To: TomasKraus
issues@serverplugins
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 11:34 UTC by Exceptions Reporter
Modified: 2013-06-08 00:13 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.04 KB, text/plain)
2013-06-07 11:34 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-06-07 11:34:43 UTC
This bug was originally marked as duplicate of bug 211962, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_15-b03
OS: Linux

User Comments:
GUEST: <Please provide a description of the problem or the steps to reproduce>




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/Enumerations$RNulls
   at org.openide.util.Enumerations.removeNulls(Enumerations.java:161)
   at org.openide.filesystems.AbstractFileSystem.existingFileObjects(AbstractFileSystem.java:410)
   at org.openide.filesystems.AbstractFileSystem.existingFileObjects(AbstractFileSystem.java:385)
   at org.openide.filesystems.JarFileSystem.refreshExistingFileObjects(JarFileSystem.java:799)
   at org.openide.filesystems.JarFileSystem.parse(JarFileSystem.java:887)
   at org.openide.filesystems.JarFileSystem.access$100(JarFileSystem.java:93)
Comment 1 Exceptions Reporter 2013-06-07 11:34:44 UTC
Created attachment 135497 [details]
stacktrace
Comment 2 Jaroslav Tulach 2013-06-07 17:20:17 UTC
Using web services that destroy Java classpath again?
Comment 3 TomasKraus 2013-06-08 00:13:03 UTC
Looks like that. But fortunately number of incomming bugs of this kind is decreasing.
7.3.1 will add all registered GF servers including version into INFO level log so we'll be able to start killing this with a single shot in case we have a log. :)

Jarda: Maybe it would be a good idea to allow some feedback trough exceptions report back to IDE in situations like this in the future. We know what's broken but poor user has no idea. And at the same time fix is so easy - upgrade GF to 3.1.2.2.

Closing this as usually.

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo