Bug 230872 - Review how fields/issues are marked to denote different states using icons, badges, font emphasis or color
Review how fields/issues are marked to denote different states using icons, b...
Status: RESOLVED DUPLICATE of bug 233472
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
7.4
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: uireviews
issues@connecteddeveloper
http://xdesign-tools.cz.oracle.com/pr...
: UI, UI_REVIEW
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 15:13 UTC by Petr Somol
Modified: 2013-08-28 12:15 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Somol 2013-06-06 15:13:52 UTC
Especially in IssueTracking framework it is desirable to be able to distinguish visually the state of issues or fields in forms. 

In the list of issues, different font colors are currently used to mark:

- black - no special state, issue is the same both locally and on server
- green - new issue on server
- blue - existing issue modified on server

currently at least one more state should be marked - locally saved but not yet submitted.

In the form of a particular issue, the fields where conflict with server value exists are marked by red error icon to the right from the field. One point raised at UI Committee meeting was the location of the icons - better would be left from the label to make it clear to which field it belongs.

Other icon (or other way of marking) may be needed to mark the "saved but not yet submitted" state.

As source of ideas Rich has supplied the following link:
http://aseng-wiki.us.oracle.com/asengwiki/display/ASUsability/Field+Editing+Conventions
Comment 1 Petr Somol 2013-06-06 15:15:13 UTC
Remark: see the URL in the header of this issue for the currently valid NB spec.
Comment 2 Jan Peska 2013-08-28 12:15:23 UTC

*** This bug has been marked as a duplicate of bug 233472 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo