Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 230730 - False warning about missed beans.xml with gf3.1.2.2
False warning about missed beans.xml with gf3.1.2.2
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: CDI
7.3.1
PC Windows 7
: P2 with 4 votes (vote)
: 7.4
Assigned To: Sergey Petrov
issues@javaee
:
: 231170 231217 231433 232292 236275 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-04 14:06 UTC by Sergey Petrov
Modified: 2013-09-23 15:19 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Petrov 2013-06-04 14:06:28 UTC
20130604 build
create web project with ee6 level with enabled cdi on gf 3.1.2.2
create new class 'NewClass' in a package
add '@Named' to class declaration
clas is marked with arror about missed beans.xml with hint to create beans/xml
Comment 1 Martin Fousek 2013-06-13 14:57:15 UTC
*** Bug 231170 has been marked as a duplicate of this bug. ***
Comment 2 Martin Fousek 2013-06-13 14:57:38 UTC
*** Bug 231217 has been marked as a duplicate of this bug. ***
Comment 3 zmirc 2013-06-18 06:33:05 UTC
The same with Apache Tomee 1.5.2 & latest stable NetBeans 7.3.1 Build 201306052037
Even though beans.xml exists and the project runs in Tomee without problems, NetBeans keep saying that beans.xml doesn't exist and shows that annoying error.
Comment 4 gholmer 2013-06-21 12:49:33 UTC
I see this in current builds of 7.4 as well.
Comment 5 Sergey Petrov 2013-06-24 13:31:38 UTC
http://hg.netbeans.org/web-main/rev/962ce64e841e fix
Comment 6 Quality Engineering 2013-06-26 02:42:22 UTC
Integrated into 'main-golden', will be available in build *201306252301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/962ce64e841e
User: Sergey B. Petrov <sj-nb@netbeans.org>
Log: #230730 fix false warning for ee6+web project
Comment 7 Sergey Petrov 2013-06-27 11:17:48 UTC
*** Bug 231433 has been marked as a duplicate of this bug. ***
Comment 8 Sergey Petrov 2013-07-05 03:45:01 UTC
*** Bug 232292 has been marked as a duplicate of this bug. ***
Comment 9 solasola 2013-08-07 13:47:55 UTC
Is it possible to disable this hint?
I could not find it in the Hints section and it is fairly distracting/annoying.
Comment 10 Sergey Petrov 2013-08-07 19:51:47 UTC
It seems it's not possible to disable, you can try either 7.4 beta or add beans.xml into META-INF also.
Comment 11 Sergey Petrov 2013-09-23 15:19:53 UTC
*** Bug 236275 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo