Bug 23029 - Form editor corrupts DataModel of JTable
Form editor corrupts DataModel of JTable
Status: CLOSED INVALID
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-02 09:32 UTC by tboerkel
Modified: 2004-03-03 22:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tboerkel 2002-05-02 09:32:46 UTC
I used 3.4 M3 to edit a form with a JTable, that I had 
generated using 3.3.1. Afterwards, the JTable's model was 
corrupted, meaning it had 0 rows and 0 cols and no titles. 
The serialized TableModel was missing in the form.xml.
I know, this is a bit vague, but I don't know how to 
reproduce this. I was lucky to have a backup. Seems, this 
needs some extensive testing from QA.
Comment 1 Richard Malaschitz 2002-05-02 13:22:55 UTC
I am not able reproduce it.
Comment 2 Tomas Pavek 2002-05-02 18:29:17 UTC
Do you try to open the form (saved in 3.4) in 3.3.1? This 
cannot work because the storage format of the table model 
was changed. But opening it in 3.4 should be OK.
Comment 3 tboerkel 2002-05-02 22:49:56 UTC
I think that's the problem, because I am switching back 
and forth between 3.3.1 and 3.4dev at the moment.
Changing the storage format for files, that are 
potentially being shared between different developers is 
not a good thing. Imagine a company, where some developers 
are still using 3.3.1 and some are already using 3.4. It's 
OK for user preferences, but not for forms IMO.
Comment 4 Tomas Pavek 2002-05-03 10:03:01 UTC
The XML format of stored TableModel was changed for good 
reason - see issue 21115. We always try to make as few 
changes as possible in the format, but this change was 
necessary.

I understand your point with sharing forms in project, but 
this particular problem cannot be solved differently. 
Generally, I see normal changing file format in new 
version of a product still being able to read files from 
older version - but you cannot expect the old version to 
read new file formats...
Comment 5 tboerkel 2002-05-03 10:54:59 UTC
I see your point. But then please warn in big letters in 
the 3.4 readme. ;-)
Comment 6 Patrick Keegan 2002-07-23 16:23:14 UTC
Proposed text for 3.4 readme:

The storage format of the table model for the JTable component has 
been changed. It is not possible to use earlier versions of the 
IDE to open forms with JTable components that were created in NetBeans 
3.4.
Comment 7 Quality Engineering 2003-06-30 18:21:12 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2003-06-30 18:26:55 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 9 Patrick Keegan 2004-03-03 22:52:37 UTC
removing RELNOTE as project importing from pre 3.4 isn't so likely
these days


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo