Bug 230176 - org.netbeans.modules.editor.indent.IndentImpl.reformatLock: LowPerformance took 10862 ms.
org.netbeans.modules.editor.indent.IndentImpl.reformatLock: LowPerformance to...
Status: RESOLVED DUPLICATE of bug 226974
Product: java
Classification: Unclassified
Component: Editor
7.3
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 12:44 UTC by Exceptions Reporter
Modified: 2013-06-10 09:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (28.91 KB, application/nps)
2013-05-23 12:44 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-05-23 12:44:30 UTC
This issue was reported manually by sdedic.
It already has 1 duplicates 


Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: OpenJDK 64-Bit Server VM, 23.2-b09, OpenJDK Runtime Environment, 1.7.0_09-icedtea-mockbuild_2012_10_17_15_53-b00
OS: Linux
Maximum slowness yet reported was 10862 ms, average is 10862
Comment 1 Exceptions Reporter 2013-05-23 12:44:32 UTC
Created attachment 134806 [details]
nps snapshot
Comment 2 Dusan Balek 2013-06-10 09:40:34 UTC
Couple of attached profiler snapshots that I've checked, show AWT EDT (inside
GsfReformatTask) waiting for the parser lock which is held by slow HTML
indexing.

*** This bug has been marked as a duplicate of bug 226974 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo