Bug 229940 - Could the NB Team restore support for Python 3. Its ridiculous to have so many different IDEs on my PC.
Could the NB Team restore support for Python 3. Its ridiculous to have so ma...
Status: STARTED
Product: python
Classification: Unclassified
Component: Code
7.3
PC Windows 7
: P3 with 1 vote (vote)
: TBD
Assigned To: Lou Dasaro
issues@python
:
: 257702 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 11:30 UTC by softwarengineer
Modified: 2017-06-22 19:39 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description softwarengineer 2013-05-18 11:30:42 UTC
Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Comment 1 Lou Dasaro 2015-05-26 02:42:47 UTC
We are diligently working to improve Python support for NetBeans 8.1, and you can test our work in progress.
See "How to install new Development build(s) for testing" at http://forums.nbpython.org/viewtopic.php?f=6&t=69
Comment 2 Lou Dasaro 2016-01-28 18:30:38 UTC
*** Bug 257702 has been marked as a duplicate of this bug. ***
Comment 3 Jenselme 2017-06-22 19:39:50 UTC
We made huge improvements for Python3 support. They will be part of the next release we plan for August. In the meantime, you can try the dev NBMs : https://bitbucket.org/Jenselme/nb-contrib/downloads/2017-06-04-nbpython-nbms.zip

Check the options in Editor/completion and Python to get the full support.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo