Bug 229660 - IDE don't support the files which name have chinese letters
IDE don't support the files which name have chinese letters
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
Macintosh Mac OS X
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
: I18N
: 227933 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 13:48 UTC by zhoufei915
Modified: 2013-11-07 16:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE 日志 (44.95 KB, text/plain)
2013-05-13 13:48 UTC, zhoufei915
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoufei915 2013-05-13 13:48:25 UTC
Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Mac OS X version 10.8.3 running on x86_64
Java; VM; Vendor = 1.7.0_21
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Comment 1 zhoufei915 2013-05-13 13:48:35 UTC
Created attachment 134371 [details]
IDE 日志
Comment 2 Marian Mirilovic 2013-05-16 09:40:32 UTC
What do you mean by 'don't support' ?
Comment 3 Jan Peska 2013-06-04 08:57:01 UTC
*** Bug 227933 has been marked as a duplicate of this bug. ***
Comment 4 Jaroslav Havlin 2013-10-11 10:02:02 UTC
Files with Chinese letters work fine for me.
(They are displayed in the Favorites window correctly, and they can be opened.)

Product Version: NetBeans IDE 7.4 RC1 (Build 201309162201)
Java: 1.7.0_40; Java HotSpot(TM) 64-Bit Server VM 24.0-b56
Runtime: Java(TM) SE Runtime Environment 1.7.0_40-b43
System: Mac OS X version 10.8.5 running on x86_64; UTF-8; en_US (nb)

Can you please try updating to JDK 7u40 and let me know whether it helps?
Thank you.
Comment 5 earthwo 2013-10-18 01:48:18 UTC
It's OK now. I used JDK 1.7.0_45 to start NetBeans today, and the Netbeans File explorer can show chinese file name correctly.
Thanks to Jaroslav Havlin and all worked for this issue.
Comment 6 Jaroslav Havlin 2013-11-07 16:31:05 UTC
OK, closing as WORKSFORME.
Thank you for your help.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo