Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 229587 - Provide Support For Creation Of Integration Tests (IT)
Provide Support For Creation Of Integration Tests (IT)
Status: RESOLVED DUPLICATE of bug 237412
Product: java
Classification: Unclassified
Component: JUnit
7.4
PC Mac OS X
: P3 (vote)
: 8.0
Assigned To: Theofanis Oikonomou
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 15:27 UTC by abien
Modified: 2014-06-04 21:21 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abien 2013-05-10 15:27:21 UTC
Current NetBeans just allows to create a Unit Test class with *Test ending for a given class. It is impossible in the wizard to enter it with the *IT extension.

1. Extend the support (=remove the restriction) and allow classes with *IT ending.
2. Allow Navigation with key bindings (currently cmd+shift+t) between classes and unit test classes OR integration tests classes. 

For background see: http://www.adam-bien.com/roller/abien/entry/a_natural_separation_of_junit
Comment 1 Theofanis Oikonomou 2013-05-15 10:45:04 UTC
(In reply to comment #0)
> Current NetBeans just allows to create a Unit Test class with *Test ending for
> a given class. It is impossible in the wizard to enter it with the *IT
> extension.
> 
> 1. Extend the support (=remove the restriction) and allow classes with *IT
> ending.

at this point I am planning for next release

> 2. Allow Navigation with key bindings (currently cmd+shift+t) between classes
> and unit test classes OR integration tests classes. 

This is solved for junit case in bug 199544

marking as enhancement. Thank you
Comment 2 markiewb 2014-06-04 21:21:29 UTC
(In reply to Theofanis Oikonomou from comment #1)
> (In reply to comment #0)
> > Current NetBeans just allows to create a Unit Test class with *Test ending for
> > a given class. It is impossible in the wizard to enter it with the *IT
> > extension.
> > 
> > 1. Extend the support (=remove the restriction) and allow classes with *IT
> > ending.
> 
> at this point I am planning for next release
> 
It has already been fixed in #237412. Now there is a checkbox "Integration Test" in the "Create/Update Tests" dialog, which changes the postfix to *IT.java

*** This bug has been marked as a duplicate of bug 237412 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo