Bug 229480 - NullPointerException at org.netbeans.modules.web.jsf.api.editor.JSFResourceBundlesProvider$1.run
NullPointerException at org.netbeans.modules.web.jsf.api.editor.JSFResourceBu...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
7.4
All All
: P1 (vote)
: 7.3.1
Assigned To: Martin Fousek
issues@javaee
EXCEPTIONS_REPORT, 73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-07 20:17 UTC by janario
Modified: 2013-06-07 08:50 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.53 KB, text/plain)
2013-05-07 20:17 UTC, janario
Details

Note You need to log in before you can comment on or make changes to this bug.
Description janario 2013-05-07 20:17:00 UTC
This issue was reported manually by janario.
It already has 2 duplicates 


Build: NetBeans IDE Dev (Build 20130507-deee69887229)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Linux

User Comments:
janario: edting xhtml

janario: Openning an xhtml




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.web.jsf.api.editor.JSFResourceBundlesProvider$1.run(JSFResourceBundlesProvider.java:93)
   at org.netbeans.modules.web.jsf.api.editor.JSFResourceBundlesProvider$1.run(JSFResourceBundlesProvider.java:77)
   at org.netbeans.modules.web.jsf.impl.metamodel.JsfModelImplementation$1.call(JsfModelImplementation.java:93)
   at org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper.runCallable(AnnotationModelHelper.java:256)
   at org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper.access$100(AnnotationModelHelper.java:79)
   at org.netbeans.modules.j2ee.metadata.model.api.support.annotation.AnnotationModelHelper$2.run(AnnotationModelHelper.java:184)
Comment 1 janario 2013-05-07 20:17:02 UTC
Created attachment 134202 [details]
stacktrace
Comment 2 janario 2013-05-07 20:29:00 UTC
This makes impossible to edit an xhtml file
Comment 3 janario 2013-05-07 20:29:18 UTC
This makes impossible to edit an xhtml file
Comment 4 Vladimir Riha 2013-05-09 06:35:42 UTC
Are you sure that 72patch-candidate is correct? :)
Comment 5 Martin Fousek 2013-05-09 07:12:31 UTC
Thanks for reporting and sorry for inconvience with these exceptions.
Fixed in web-main #f80f8e70d867 and prevented another NPE.
Comment 6 Martin Fousek 2013-05-09 07:16:33 UTC
Guys please could you send me also bundle setup of your projects where this happened? It means:
- part of your faces-config.xml where are bundles registered
- structure of your project (packages + bundle names)

-> It's probable that navigation for your resource bundles will not work properly without these additional information, thanks a lot!
Comment 7 Martin Fousek 2013-05-09 07:20:01 UTC
Martine, could I ask you for review of fix for this NPE please? Thanks in advance.
Comment 8 Martin Janicek 2013-05-09 08:21:05 UTC
The patch looks fine and safe to me !
Comment 9 Martin Fousek 2013-05-09 08:29:00 UTC
(In reply to comment #8)
> The patch looks fine and safe to me !

Thanks for quick review.
Comment 10 Quality Engineering 2013-05-10 02:37:29 UTC
Integrated into 'main-golden', will be available in build *201305092300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f80f8e70d867
User: Martin Fousek <marfous@netbeans.org>
Log: #229480 - NullPointerException at org.netbeans.modules.web.jsf.api.editor.JSFResourceBundlesProvider$1.run
Comment 11 Vladimir Riha 2013-05-14 07:24:02 UTC
I cannot reproduce it even before the fix but it looks safe, verified


Product Version: NetBeans IDE Dev (Build 201305132300)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-41-generic-pae running on i386; UTF-8; en_US (nb)
Comment 12 Vladimir Riha 2013-05-14 07:55:49 UTC
Verified, but status should be changed after verification in 7.3.1, sorry for spam
Comment 13 Martin Fousek 2013-05-14 15:03:12 UTC
Transplanted as releases #8ed597cf8579.
Comment 14 Quality Engineering 2013-05-15 00:20:01 UTC
Integrated into 'releases', will be available in build *201305142200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/8ed597cf8579
User: Martin Fousek <marfous@netbeans.org>
Log: #229480 - NullPointerException at org.netbeans.modules.web.jsf.api.editor.JSFResourceBundlesProvider$1.run
(transplanted from f80f8e70d8670b3d839175c53899c5704a2bdb73)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo