Bug 229407 - AssertionError: actual and formal argument lists differ in length
AssertionError: actual and formal argument lists differ in length
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.4
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
: 234034 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-06 12:58 UTC by J Bachorik
Modified: 2016-07-07 07:19 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (9.17 KB, text/plain)
2013-05-06 12:59 UTC, J Bachorik
Details
stacktrace (5.46 KB, text/plain)
2013-07-05 00:41 UTC, MackSix
Details
stacktrace (8.92 KB, text/plain)
2013-07-19 08:42 UTC, J Bachorik
Details
stacktrace (4.13 KB, text/plain)
2013-08-02 04:16 UTC, J Bachorik
Details
stacktrace (8.46 KB, text/plain)
2013-08-13 15:30 UTC, theshadow27
Details
stacktrace (1.89 KB, text/plain)
2013-08-27 12:10 UTC, theshadow27
Details
stacktrace (4.33 KB, text/plain)
2014-03-25 15:18 UTC, theshadow27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J Bachorik 2013-05-06 12:58:58 UTC
Build: NetBeans IDE Dev (Build 201305052300)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Linux

User Comments:
yardus: opening openjdk project




Stacktrace: 
java.lang.AssertionError: actual and formal argument lists differ in length
   at com.sun.tools.javac.util.Assert.error(Assert.java:133)
   at com.sun.tools.javac.comp.Attr.checkMethod(Attr.java:3823)
   at com.sun.tools.javac.comp.Attr.checkIdInternal(Attr.java:3607)
   at com.sun.tools.javac.comp.Attr.checkMethodIdInternal(Attr.java:3508)
   at com.sun.tools.javac.comp.Attr.checkMethodId(Attr.java:3486)
   at com.sun.tools.javac.comp.Attr.checkId(Attr.java:3474)
Comment 1 J Bachorik 2013-05-06 12:59:00 UTC
Created attachment 134137 [details]
stacktrace
Comment 2 MackSix 2013-07-05 00:41:22 UTC
Created attachment 136734 [details]
stacktrace

1. With a Mercurial Project, Team>>View and popup asked if I wanted to install hgk so I accepted it.
2. Restarted NetBeans
3. With same Mercurial Project, Team>>View while scanning was taken place.
This AssertionError occured.
Comment 3 MackSix 2013-07-05 01:06:23 UTC
Afterwards, the project JEditProject has a red badge on it that said there were files with error. I could not make it go away restarting NetBeans. I had to shutdown NetBeans, delete the cache directory and restart it and the error badge went away.
Comment 4 J Bachorik 2013-07-19 08:42:42 UTC
Created attachment 137428 [details]
stacktrace

background scanning of the openjdk8-tl/jdk/test sources
Comment 5 J Bachorik 2013-08-02 04:16:44 UTC
Created attachment 138164 [details]
stacktrace

copy paste of a java code
Comment 6 Dusan Balek 2013-08-07 11:42:30 UTC
*** Bug 234034 has been marked as a duplicate of this bug. ***
Comment 7 theshadow27 2013-08-13 15:30:50 UTC
Created attachment 138645 [details]
stacktrace

Revert SVN modifications from gutter hint
Comment 8 theshadow27 2013-08-27 12:10:12 UTC
Created attachment 139306 [details]
stacktrace

Deleted class prefix "ClassName.staticMethod(..)" -> "staticMethod(..)" within class with arguments that were not real variables
Comment 9 theshadow27 2014-03-25 15:18:46 UTC
Created attachment 146313 [details]
stacktrace

Editing an inner class
Comment 10 Martin Balin 2016-07-07 07:19:07 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo