Bug 229330 - Exception only happens in Netbeans, not Eclipse ( libdgx library)
Exception only happens in Netbeans, not Eclipse ( libdgx library)
Status: RESOLVED INVALID
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
7.3
PC Windows 7 x64
: P2 (vote)
: 7.4
Assigned To: Milos Kleint
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-03 13:38 UTC by Andre_Lopes_2012
Modified: 2013-05-13 12:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Project with the code described (8.73 MB, application/x-zip-compressed)
2013-05-03 13:51 UTC, Andre_Lopes_2012
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre_Lopes_2012 2013-05-03 13:38:30 UTC
After inserting the libraries and running a simple code, it gives that exception.
I used the same code/libs in eclipse and no Exceptions happened.
The code and library can be checked at forum.

Also, i created a ticket with them , but it seems to be an IDE issue.

Ticket : http://code.google.com/p/libgdx/issues/detail?id=1419

Forum post that i made : http://www.java-gaming.org/topics/first-time-with-libgdx-netbeans-user/29459/view.html

Image link : http://img833.imageshack.us/img833/3614/javagameerror.jpg

CODE: SELECT ALL
run:
org.lwjgl.LWJGLException: Could not locate OpenAL library.
   at org.lwjgl.openal.AL.create(AL.java:151)
   at org.lwjgl.openal.AL.create(AL.java:102)
   at org.lwjgl.openal.AL.create(AL.java:201)
   at com.badlogic.gdx.backends.openal.OpenALAudio.<init>(OpenALAudio.java:70)
   at com.badlogic.gdx.backends.lwjgl.LwjglApplication.<init>(LwjglApplication.java:80)
   at com.badlogic.gdx.backends.lwjgl.LwjglApplication.<init>(LwjglApplication.java:64)
   at com.badlogic.gdx.backends.lwjgl.LwjglApplication.<init>(LwjglApplication.java:56)
   at Main.Main.main(Main.java:29)
Tyrian: Creating game
Tyrian: Resizing game to: 800 x 480
FPSLogger: fps: 61
FPSLogger: fps: 60
Tyrian: Pausing game
Tyrian: Disposing game
Java Result: -1
CONSTRUÍDO COM SUCESSO (tempo total: 2 segundos)
Comment 1 Andre_Lopes_2012 2013-05-03 13:51:31 UTC
Created attachment 134084 [details]
Project with the code described
Comment 2 Marian Mirilovic 2013-05-06 20:30:11 UTC
Reassign to projects for evaluation ...
Comment 3 Andre_Lopes_2012 2013-05-06 20:38:05 UTC
What you mean ?
Comment 4 Milos Kleint 2013-05-07 06:13:36 UTC
when creating the project have you checked the "Use dedicated folder for storing libraries" checkbox? You can double check in the Project properties under libraries category. If "Libraries" text field points to a properties file, you are using non-global libraries

if so, it's likely that your library jar files were copied to the libraries folder in the project and this library apparently needs native libs next to the jar. And these are missing. Copy them there.
Comment 5 Milos Kleint 2013-05-13 12:24:00 UTC
please read:

https://code.google.com/p/libgdx/wiki/ProjectSetup
https://code.google.com/p/libgdx/wiki/MavenProjectSetup


it appears to me that you've got your platforms mixed up. If you are building a desktop app, the -android.jar and -gwt.jar are not to be present. I've got a (different) stacktrace before removing them, after removing the app started but eventually failed (after running apparently)

I believe the problem is a configuration problem on your side.  From what I read in the docs, just adding the (right) dependencies should work. Please note that  Run action in the IDE could be influenced by Compile on Save feature. Turn it off and optionally after building the project try running from cmd line from the dist/ folder (as per dist/README)

please reopen with more details describing what is the issue in netbeans..


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo