Bug 229278 - org.netbeans.swing.tabcontrol.TabbedContainer.paint: LowPerformance took 72725 ms.
org.netbeans.swing.tabcontrol.TabbedContainer.paint: LowPerformance took 7272...
Status: RESOLVED DUPLICATE of bug 189647
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
7.3
All All
: P2 with 1 vote (vote)
: TBD
Assigned To: Dusan Balek
issues@versioncontrol
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-02 13:55 UTC by Stevie69
Modified: 2013-05-29 13:26 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (958.02 KB, application/nps)
2013-05-02 13:56 UTC, Stevie69
Details
nps snapshot (25.60 KB, application/nps)
2013-05-11 16:28 UTC, kinta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stevie69 2013-05-02 13:55:55 UTC
This bug was originally marked as duplicate of bug 189647, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.6-b01, Java(TM) SE Runtime Environment, 1.6.0_31-b05
OS: Windows 7

User Comments:
Stevie69: Source/Format for a large Java file



Maximum slowness yet reported was 72725 ms, average is 72725
Comment 1 Stevie69 2013-05-02 13:56:07 UTC
Created attachment 134040 [details]
nps snapshot
Comment 2 Stanislav Aubrecht 2013-05-07 10:45:13 UTC
DiffSidebar acquires document read lock when painting.
Comment 3 Ondrej Vrabec 2013-05-07 11:20:57 UTC
org.netbeans.modules.java.source.save.Reformatter.reformat()	99.87181	62,060 ms (99.9%)	62,060 ms
or 
org.netbeans.modules.editor.indent.TaskHandler$MimeItem.runTask()	99.87181	62,060 ms (99.9%)	62,060 ms
is holding the write long for too long.
Comment 4 kinta 2013-05-11 16:28:52 UTC
Created attachment 134318 [details]
nps snapshot

switching between browser and netbeans
Comment 5 Dusan Balek 2013-05-29 13:26:11 UTC
Most of the attached snapshots show extremely slow javascript formatting.

*** This bug has been marked as a duplicate of bug 189647 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo