Bug 229135 - java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Filesystems
7.4
All All
: P2 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
: 228350 229171 229178 229372 240414 (view as bug list)
Depends on:
Blocks: 229178
  Show dependency treegraph
 
Reported: 2013-04-29 06:16 UTC by mienamoo
Modified: 2014-01-17 10:33 UTC (History)
31 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.54 KB, text/plain)
2013-04-29 06:16 UTC, mienamoo
Details
stacktrace (7.61 KB, text/plain)
2013-04-30 04:25 UTC, Chiana
Details
stacktrace (2.51 KB, text/plain)
2013-04-30 10:46 UTC, dynamite
Details
stacktrace (2.49 KB, text/plain)
2013-04-30 10:49 UTC, dynamite
Details
stacktrace (1.65 KB, text/plain)
2013-05-11 12:10 UTC, Lukas Jungmann
Details
stacktrace (1.65 KB, text/plain)
2013-05-14 07:01 UTC, Jiri Skrivanek
Details
stacktrace (10.18 KB, text/plain)
2013-05-15 12:55 UTC, mslama
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2013-04-29 06:16:39 UTC
Build: NetBeans IDE Dev (Build 201304272301)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_17-b02
OS: Windows 7

User Comments:
mienamoo: Trying to open a project, while the Maven repo index was in the process of being transferred.




Stacktrace: 
java.nio.file.InvalidPathException: Illegal char <:> at index 0: ::{20D04FE0-3AEA-1069-A2D8-08002B30309D}
   at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182)
   at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)
   at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
   at sun.nio.fs.WindowsPath.parse(WindowsPath.java:94)
   at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:255)
   at java.io.File.toPath(File.java:2069)
Comment 1 mienamoo 2013-04-29 06:16:40 UTC
Created attachment 133903 [details]
stacktrace
Comment 2 Milos Kleint 2013-04-29 06:31:05 UTC
is ::{20D04FE0-3AEA-1069-A2D8-08002B30309D} some sort of directory path that you were browsing?
Comment 3 mienamoo 2013-04-29 06:58:34 UTC
No, it was something like "C:\Projects\Tests\SomeFolder". I was looking for some random Maven project to test something in the IDE, so I don't recall exactly which folder it was.
Comment 4 Milos Kleint 2013-04-29 16:13:23 UTC
*** Bug 229171 has been marked as a duplicate of this bug. ***
Comment 5 Maksim Khramov 2013-04-29 19:07:21 UTC
Product Version: NetBeans IDE Dev (Build 201304282301)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01

My Steps to reproduce:
Create fresh Ant based java project.
Open properties window and click on add folder.
Create new folder named resources.
Close properties window
Click on resources node.
The endless exception occurs:
java.nio.file.InvalidPathException: Illegal char <O> at index 36: C:\Oracle\NetBeans Dev 201304282301\O
        at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182)
        at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)
        at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
        at sun.nio.fs.WindowsPath.parse(WindowsPath.java:94)
        at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:255)
        at java.io.File.toPath(File.java:2069)
        at org.openide.util.Utilities.toURI(Utilities.java:3114)
        at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:875)
        at org.openide.loaders.DataFolder$FolderNode.createNodeTransferable(DataFolder.java:1421)
        at org.openide.loaders.DataFolder$FolderNode.createPasteTypes(DataFolder.java:1402)
        at org.openide.nodes.AbstractNode.getPasteTypes(AbstractNode.java:543)
        at org.openide.nodes.FilterNode.getPasteTypes(FilterNode.java:684)
        at org.netbeans.spi.java.project.support.ui.PackageViewChildren$PackageNode.getPasteTypes(PackageViewChildren.java:815)
        at org.openide.nodes.FilterNode.getPasteTypes(FilterNode.java:684)
        at org.netbeans.modules.openide.explorer.ExplorerActionsImpl.updatePasteTypes(ExplorerActionsImpl.java:351)
        at org.netbeans.modules.openide.explorer.ExplorerActionsImpl.updatePasteAction(ExplorerActionsImpl.java:337)
        at org.netbeans.modules.openide.explorer.ExplorerActionsImpl.updateActions(ExplorerActionsImpl.java:278)
        at org.netbeans.modules.openide.explorer.ExplorerActionsImpl$ActionStateUpdater.run(ExplorerActionsImpl.java:798)
Comment 6 Chiana 2013-04-30 04:25:27 UTC
Created attachment 133955 [details]
stacktrace

Was trying to open a project, clicked on a path
Comment 7 Milos Kleint 2013-04-30 06:14:35 UTC
*** Bug 228350 has been marked as a duplicate of this bug. ***
Comment 8 Milos Kleint 2013-04-30 06:15:50 UTC
keeps on coming from various pieces of code in recent builds, reassigning to filesystems for evaluation
Comment 9 dynamite 2013-04-30 10:46:33 UTC
Created attachment 133968 [details]
stacktrace

Closing a project.
Comment 10 dynamite 2013-04-30 10:49:33 UTC
Created attachment 133969 [details]
stacktrace

Opening project.
Comment 11 Exceptions Reporter 2013-04-30 10:49:37 UTC
This bug already has 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=200290
Comment 12 Milos Kleint 2013-05-06 06:44:25 UTC
*** Bug 229372 has been marked as a duplicate of this bug. ***
Comment 13 Exceptions Reporter 2013-05-08 08:58:47 UTC
This bug already has 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=200290
Comment 14 Lukas Jungmann 2013-05-11 12:10:51 UTC
Created attachment 134316 [details]
stacktrace

trying to clean & build mvn project, looks like '\t' in path on win is causing troubles
Comment 15 280Z28 2013-05-11 22:03:18 UTC
The conversion from \t to hard tabs (and other escapes for \r and \n) in Windows paths occurs in the JSONParser, which appears to be added to the Maven project system originally in 71289f0dadeb.
Comment 16 markiewb 2013-05-13 20:00:21 UTC
Removed by Administrator - per request from repoter
Comment 17 Jiri Skrivanek 2013-05-14 07:01:53 UTC
Created attachment 134403 [details]
stacktrace

While creating Maven EAR project with WebLogic server.
Comment 18 markiewb 2013-05-14 19:16:16 UTC
I also happens when building a maven application on a windows platform, but only if the application is located in a special directory. The build is stuck when this happens.

For example the project is located at "E:\wsgitnb\basis\product.nom.reporting". Within the exception you can see that the path is rewritten to "E:\wsgitnasis\product.nom.reporting", which is wrong. When the project is moved to a different directory (f.e. "E:\wsgitnb\others\product.nom.reporting") then it works, the build isn't stuck and is executed successfully. 

SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor org.netbeans.modules.maven.execute.CommandLineOutputHandler$Output
java.nio.file.InvalidPathException: Illegal char > at index 10: E:\wsgitnasis\product.nom.reporting
 at sun.nio.fs.WindowsPathParser.normalize(WindowsPathParser.java:182)
 at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:153)
 at sun.nio.fs.WindowsPathParser.parse(WindowsPathParser.java:77)
 at sun.nio.fs.WindowsPath.parse(WindowsPath.java:94)
 at sun.nio.fs.WindowsFileSystem.getPath(WindowsFileSystem.java:255)
 at java.io.File.toPath(File.java:2069)
 at org.openide.util.Utilities.toURI(Utilities.java:3114)
 at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:875)
 at org.netbeans.modules.maven.execute.cmd.ExecProject.findProject(ExecProject.java:74)
 at org.netbeans.modules.maven.execute.CommandLineOutputHandler$Output.processExecEvent(CommandLineOutputHandler.java:405)
 at org.netbeans.modules.maven.execute.CommandLineOutputHandler$Output.run(CommandLineOutputHandler.java:270)
 at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2042)
SEVERE [global]
java.io.CharConversionException: Invalid XML character &#8;.
 at org.openide.xml.XMLUtil.checkContentCharacters(XMLUtil.java:800)
 at org.openide.xml.XMLUtil.toElementContent(XMLUtil.java:630)
 at org.netbeans.modules.notifications.NotificationImpl.createDetails(NotificationImpl.java:245)
Caused: java.lang.IllegalArgumentException
 at org.netbeans.modules.notifications.NotificationImpl.createDetails(NotificationImpl.java:247)
 at org.netbeans.modules.notifications.NotificationImpl.initDecorations(NotificationImpl.java:173)
 at org.netbeans.modules.notifications.center.NotificationCenterManager$3.run(NotificationCenterManager.java:227)
 at org.netbeans.modules.notifications.center.NotificationCenterManager.firePropertyChange(NotificationCenterManager.java:233)
 at org.netbeans.modules.notifications.center.NotificationCenterManager.add(NotificationCenterManager.java:101)
 at org.netbeans.modules.notifications.NotificationDisplayerImpl.add(NotificationDisplayerImpl.java:111)
 at org.netbeans.modules.notifications.NotificationDisplayerImpl.notify(NotificationDisplayerImpl.java:90)
 at org.netbeans.core.NotifyExcPanel$ExceptionFlasher.notify(NotifyExcPanel.java:617)
 at org.netbeans.core.NotifyExcPanel$ExceptionFlasher.access$600(NotifyExcPanel.java:610)
 at org.netbeans.core.NotifyExcPanel$2.run(NotifyExcPanel.java:349)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
 at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
 at java.awt.EventQueue.access$200(EventQueue.java:103)
 at java.awt.EventQueue$3.run(EventQueue.java:688)
 at java.awt.EventQueue$3.run(EventQueue.java:686)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:697)
 at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

----
Using a dev build from last week, WinXP 32bit and JDK 1.7.x.
Comment 19 MackSix 2013-05-14 19:43:21 UTC
This is reproducible for me and has nothing to do with a Maven project.

See https://netbeans.org/bugzilla/show_bug.cgi?id=229171
Comment 20 mslama 2013-05-15 12:55:56 UTC
Created attachment 134471 [details]
stacktrace

Opening project
Comment 21 MackSix 2013-05-16 20:06:04 UTC
This does not happen when I open project and change directories now in:

Product Version: NetBeans IDE Dev (Build 201305152300)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 22 Jaroslav Havlin 2013-06-03 12:21:22 UTC
It should work fine now, the bug has been fixed here:
http://hg.netbeans.org/core-main/rev/501be6257f1e
Comment 23 Milos Kleint 2013-06-04 09:28:08 UTC
*** Bug 229178 has been marked as a duplicate of this bug. ***
Comment 24 mienamoo 2013-06-04 13:15:08 UTC
So far so good. Haven't seen it with build 201306032301 yet. :)
Comment 25 Jaroslav Havlin 2014-01-17 10:33:43 UTC
*** Bug 240414 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo