Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 229060 - JDK Folder appears as a tab on startup
JDK Folder appears as a tab on startup
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Launchers&CLI
7.3
PC Windows 7
: P1 with 1 vote (vote)
: 7.4
Assigned To: Libor Fischmeistr
issues@platform
: REGRESSION
: 231391 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-26 09:36 UTC by adam_felix_fps
Modified: 2013-07-10 21:39 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Image of the issue (13 bytes, text/plain)
2013-04-29 07:47 UTC, adam_felix_fps
Details
Image of the issue (55.70 KB, image/jpeg)
2013-04-29 07:49 UTC, adam_felix_fps
Details
messages.log standard dev profile (35.36 KB, application/octet-stream)
2013-06-07 10:18 UTC, adam_felix_fps
Details
messages.log using a non standard fodler as user folder (devtest) (29.93 KB, application/octet-stream)
2013-06-07 10:19 UTC, adam_felix_fps
Details
Resources for this bug after attempting to perform Java SE to ALL sanity Tests (17.76 KB, application/octet-stream)
2013-06-17 21:10 UTC, satory
Details
messages log with addition info logings (43.39 KB, application/octet-stream)
2013-06-20 12:31 UTC, Jan Peska
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adam_felix_fps 2013-04-26 09:36:18 UTC
Product Version = NetBeans IDE Dev (Build 201304242301)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_11
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.6-b04
The JDK folder appears as a tab in the left pane on startup every time.  I close it but on the next restart it is back. Not sure if I can disable this is settings or the conf file but would be good if I could.  Many Thanks
Comment 1 Marian Mirilovic 2013-04-29 06:33:27 UTC
What do you mean by 'JDK folder appears as a tab in the left' ? Could you provide screenshot + attach messages.log file and reopen ? Thanks in advance.
Comment 2 adam_felix_fps 2013-04-29 07:47:49 UTC
Created attachment 133912 [details]
Image of the issue

This appears on startup in the left hand pane next to the projects folder.
Comment 3 adam_felix_fps 2013-04-29 07:49:11 UTC
Created attachment 133913 [details]
Image of the issue

First image appeared to upload wrongly.  Trying again.
Comment 4 Jan Peska 2013-06-04 08:31:51 UTC
Well, do you recall how did it get there? I'm not familiar with any action which can add a folder as a tab. If it was unintentional to have it there please try to run netbeans with new userdir - run netbeans with switch --userdir "C:\your\path\userdir". Please reopen when the questions are answered.

Thanks
Comment 5 adam_felix_fps 2013-06-04 08:35:55 UTC
This is still happening on a brand new install with a brand new user directory.  The JDK folder appears as a tab in the left pane on every startup.
Comment 6 Jan Peska 2013-06-04 08:56:00 UTC
And you have added in there by drag-and-droping the folder into the NB?
Comment 7 adam_felix_fps 2013-06-04 09:02:18 UTC
No I have never added it there.  It just appeared the first time I installed a nightly build and has continued to appear ever since.  I remove it on startup and each time I restart it is back.  It is nothing that I ever did.
Comment 8 Jan Peska 2013-06-04 09:29:44 UTC
OK, please run it with --userdir PATH where PATH is path to a nonexisting folder to be your userdir. Try it and than attach messages log - see http://wiki.netbeans.org/FaqLogMessagesFile
Comment 9 Jan Peska 2013-06-05 08:20:05 UTC
Reopen as soon as the messages log is attached, thanks.
Comment 10 adam_felix_fps 2013-06-07 10:18:17 UTC
Created attachment 135492 [details]
messages.log standard dev profile

Messages.log for when the issue happens using the standard dev profile
Comment 11 adam_felix_fps 2013-06-07 10:19:30 UTC
Created attachment 135493 [details]
messages.log using a non standard fodler as user folder (devtest)

Messages.log for when the issue does NOT happen using a non standard user folder as requested
Comment 12 adam_felix_fps 2013-06-07 10:21:05 UTC
Reopened attaching two messages.log files one for when it happens and one for when it doesn't.  The main difference between the profiles is that the standard one obviously has no plugins and is using the standard theme.  The standard dev profile is using Nimbus Look and Feel and has one plugin installed - Restart IDE.
Comment 13 Stepan Zebra 2013-06-14 15:28:52 UTC
I can reproduce this issue on 7.4 Beta build. The "jdk tab" appears after installation of JIRA plugin.
Comment 14 Vladimir Riha 2013-06-17 20:37:34 UTC
*** Bug 231391 has been marked as a duplicate of this bug. ***
Comment 15 satory 2013-06-17 21:10:53 UTC
Created attachment 135921 [details]
Resources for this bug after attempting to perform Java SE to ALL sanity Tests

I too have spotted this today.  

It occurred when I attempted to install all plugins from the Java SE version of the Beta 7.4 build, as part of the Sanity Tests.

I have included all the resources for this bug I have, including a thread dump, and logs.
Comment 16 Jiri Rechtacek 2013-06-20 11:26:48 UTC
It's reproducible on latest 7.4 Beta(build 2013-06-19_23-57-12) with Win 7 on every restart IDE (e.g. Export/Import Options Settings)
Comment 17 Jan Peska 2013-06-20 12:31:00 UTC
Created attachment 136079 [details]
messages log with addition info logings

I've added two info loggings to find out who is creating this JDK tab. It seems that it is invoked from org.netbeans.api.sendopts.CommandLine.process(CommandLine.java:317). I do not dare to go any lower so I'll reassign this bug for further evaluation.
Comment 18 Jan Peska 2013-06-20 12:36:47 UTC
Notes that this tab is always opened after restarting the IDE from NB e.g.:
-import options settings
-IDE ask you to restart
-after IDE is restarted the JDK tab is shown

FYI - important info loggings:

java.lang.Exception
	at org.netbeans.modules.openfile.DefaultOpenFileImpl.open(DefaultOpenFileImpl.java:528)
	at org.netbeans.modules.openfile.OpenFile.open(OpenFile.java:72)
	at org.netbeans.modules.openfile.OpenFile.openFile(OpenFile.java:97)
	at org.netbeans.modules.openfile.Handler.openFile(Handler.java:127)
	at org.netbeans.modules.openfile.Handler.process(Handler.java:90)
	at org.netbeans.modules.sendopts.DefaultProcessor.process(DefaultProcessor.java:202)
	at org.netbeans.spi.sendopts.Option$1.process(Option.java:387)
	at org.netbeans.api.sendopts.CommandLine.process(CommandLine.java:317)
	at org.netbeans.modules.sendopts.HandlerImpl.execute(HandlerImpl.java:62)
	at org.netbeans.modules.sendopts.Handler.cli(Handler.java:69)
	at org.netbeans.CLIHandler.notifyHandlers(CLIHandler.java:234)
	at org.netbeans.core.startup.CLICoreBridge.cli(CLICoreBridge.java:82)
	at org.netbeans.CLIHandler.notifyHandlers(CLIHandler.java:234)
	at org.netbeans.CLIHandler$1.exec(CLIHandler.java:268)
	at org.netbeans.CLIHandler.finishInitialization(CLIHandler.java:447)
	at org.netbeans.MainImpl.finishInitialization(MainImpl.java:254)
	at org.netbeans.Main.finishInitialization(Main.java:87)
	at org.netbeans.core.startup.Main.start(Main.java:316)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
	at java.lang.Thread.run(Thread.java:722)
INFO [org.netbeans.modules.openfile.DefaultOpenFileImpl]
java.lang.Exception
	at org.netbeans.modules.openfile.DefaultOpenFileImpl.open(DefaultOpenFileImpl.java:528)
	at org.netbeans.modules.openfile.DefaultOpenFileImpl.run(DefaultOpenFileImpl.java:513)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:697)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
INFO [org.netbeans.core.windows.services.NodeOperationImpl]
java.lang.Exception
	at org.netbeans.core.windows.services.NodeOperationImpl.explore(NodeOperationImpl.java:100)
	at org.netbeans.modules.openfile.DefaultOpenFileImpl$4.run(DefaultOpenFileImpl.java:617)
	at org.netbeans.core.windows.WindowManagerImpl$Exclusive$1.run(WindowManagerImpl.java:1558)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:727)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:697)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Reassigning to Platform/Launchers
Comment 19 Libor Fischmeistr 2013-06-20 17:02:27 UTC
Caused by launcher. Reproducible also on trunk - in etc/netbeans.conf has to be specified netbeans_jdkhome property.

Than the value of netbeans_jdkhome property is badly propagated to IDE and then it's the opened in tab...
Comment 20 Jiri Rechtacek 2013-06-21 08:05:24 UTC
(In reply to comment #19)
> Caused by launcher. Reproducible also on trunk - in etc/netbeans.conf has to be
> specified netbeans_jdkhome property.
> 
> Than the value of netbeans_jdkhome property is badly propagated to IDE and then
> it's the opened in tab...

Libor, is it any regression? Such behaviour haven't been faced in recent older builds. What caused this change? Thanks
Comment 21 Libor Fischmeistr 2013-06-21 09:37:32 UTC
(In reply to comment #20)
> (In reply to comment #19)
> > Caused by launcher. Reproducible also on trunk - in etc/netbeans.conf has to be
> > specified netbeans_jdkhome property.
> > 
> > Than the value of netbeans_jdkhome property is badly propagated to IDE and then
> > it's the opened in tab...
> 
> Libor, is it any regression? Such behaviour haven't been faced in recent older
> builds. What caused this change? Thanks

Yes it is regression due to http://hg.netbeans.org/core-main/rev/17d586edf21a
issue 227068
Comment 22 Libor Fischmeistr 2013-06-21 12:37:50 UTC
Fixed in http://hg.netbeans.org/core-main/rev/90f32b7f2a94

The http://hg.netbeans.org/core-main/rev/17d586edf21a changeset did not caused directly this bug, but helped to show another bug.

Thanks to all for logs and other supporting information.
Comment 23 Quality Engineering 2013-06-25 02:43:19 UTC
Integrated into 'main-golden', will be available in build *201306242301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/90f32b7f2a94
User: Libor Fischmeistr <lfischmeistr@netbeans.org>
Log: #229060: JDK Folder appears as a tab on startup
Comment 24 markiewb 2013-07-10 21:39:39 UTC
I haven't seen this issue for a while. 
Verified in 201307011244 - a forced restart of the IDE after adding/removing plugins didn't show up the tab.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo