Bug 229033 - org.openide.filesystems.FSException: Cannot rename file Modules/.nbattrs~ in C:\Documents and Settings\john.fo\Application Data\NetBeans\7.2.1\config to Modules/.nbattrs. New file exists: false. Renam
org.openide.filesystems.FSException: Cannot rename file Modules/.nbattrs~ in ...
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Filesystems
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-25 20:13 UTC by Exceptions Reporter
Modified: 2013-08-19 16:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.18 KB, text/plain)
2013-04-25 20:13 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-04-25 20:13:35 UTC
This bug was originally marked as duplicate of bug 205001, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2.1 (Build 201210100934)
VM: Java HotSpot(TM) Client VM, 17.1-b03, Java(TM) SE Runtime Environment, 1.6.0_22-b04
OS: Windows XP

User Comments:
GUEST: Netbeans is just endlessly 'scanning' the project at 100%, and eating up a lot of cpu




Stacktrace: 
org.openide.filesystems.FSException: Cannot rename file Modules/.nbattrs~ in C:\Documents and Settings\john.fo\Application Data\NetBeans\7.2.1\config to Modules/.nbattrs. New file exists: false. Rename result: false.
   at org.openide.filesystems.LocalFileSystem.rename(LocalFileSystem.java:312)
   at org.openide.filesystems.LocalFileSystem$Impl.rename(LocalFileSystem.java:598)
   at org.openide.filesystems.DefaultAttributes.saveTable(DefaultAttributes.java:621)
   at org.openide.filesystems.DefaultAttributes.writeAttribute(DefaultAttributes.java:440)
   at org.netbeans.core.startup.layers.LocalFileSystemEx$DelegatingAttributes.writeAttribute(LocalFileSystemEx.java:209)
   at org.openide.filesystems.AbstractFileObject.setAttribute(AbstractFileObject.java:357)
Comment 1 Exceptions Reporter 2013-04-25 20:13:36 UTC
Created attachment 133822 [details]
stacktrace
Comment 2 Jaroslav Havlin 2013-08-19 16:06:18 UTC
Only one report from older release 7.2.1.
The file couldn't be probably really deleted due to some filesystem problem,
or the system was under heavy load (maybe scanning, maybe some external process).

I cannot reproduce the problem, closing for now. If you can provide additional information, please reopen. Thank you.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo