Bug 229022 - Show References is not available in Variables/Watches view.
Show References is not available in Variables/Watches view.
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
7.3
All All
: P3 (vote)
: 7.3.1
Assigned To: Martin Entlicher
issues@debugger
73patch2-verified
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-25 15:42 UTC by Martin Entlicher
Modified: 2013-05-13 12:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2013-04-25 15:42:29 UTC
The Show References heap walker action is not available on the context menu in Variables/Watches view.
Comment 1 Martin Entlicher 2013-04-25 15:58:49 UTC
Fixed by changeset:   251922:ba34f9678002
http://hg.netbeans.org/core-main/rev/ba34f9678002
Comment 2 Quality Engineering 2013-04-28 02:19:31 UTC
Integrated into 'main-golden', will be available in build *201304272301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ba34f9678002
User: mentlicher@netbeans.org
Log: #229022: Add forgotten DebuggerServiceRegistrations into DebuggerProcessor.
Comment 3 Jiri Kovalsky 2013-04-29 13:08:42 UTC
Product Version: NetBeans IDE Dev (Build 201304282301)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.0.0-12-generic running on amd64; UTF-8; cs_CZ (nb)
User directory: /home/cesilko/.netbeans/dev
Cache directory: /home/cesilko/.cache/netbeans/dev

Verified. I approve integration to release73 branch.
Comment 4 Martin Entlicher 2013-05-03 13:44:42 UTC
Thanks. The fix was pushed into release73 branch as
changeset:   260424:f2cf2743f4d4, spec. version increase by
changeset:   260425:17a5720e1c7f

https://hg.netbeans.org/releases/rev/f2cf2743f4d4
https://hg.netbeans.org/releases/rev/17a5720e1c7f
Comment 5 Quality Engineering 2013-05-05 00:26:36 UTC
Integrated into 'releases', will be available in build *201305042200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/f2cf2743f4d4
User: mentlicher@netbeans.org
Log: #229022: Add forgotten DebuggerServiceRegistrations into DebuggerProcessor.
Comment 6 Jiri Kovalsky 2013-05-10 12:56:53 UTC
I am sorry but I cannot verify this fix in Patch 2. Although I see the module upgraded correctly [1] the "Show References" action in popup menu of any objects in Variables view does not show up.

[1] org.netbeans.api.debugger/1 [1.40.2 201305092200]
Comment 7 Martin Entlicher 2013-05-10 13:07:14 UTC
I confirm this. It's unfortunate, that the spec. version of debugger.jpda.heapwalk was not changed as well. This module needs to be re-compiled so that the action gets added. And it needs to be a part of the update, since debugger.jpda.heapwalk defines the action.
Comment 8 Martin Entlicher 2013-05-10 13:33:50 UTC
The spec. version of debugger.jpda.heapwalk is increased by changeset:   261054:5c7cb9e7d72c. The Show References action should be registered by recompilation and update of this module.
https://hg.netbeans.org/releases/rev/5c7cb9e7d72c
Comment 9 Quality Engineering 2013-05-11 00:17:23 UTC
Integrated into 'releases', will be available in build *201305102200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/5c7cb9e7d72c
User: mentlicher@netbeans.org
Log: #229022: Increasing spec. version in order to re-compile this module so that the DebuggerServiceRegistrations annotation is processed correctly.
Comment 10 Jiri Kovalsky 2013-05-13 12:13:11 UTC
Great. Verified with the updated module catalogue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo