Bug 229017 - org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.getFileObject: LowPerformance took 42205 ms.
org.netbeans.modules.masterfs.filebasedfs.FileBasedFileSystem.getFileObject: ...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-25 14:07 UTC by Exceptions Reporter
Modified: 2013-07-26 10:17 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (575.59 KB, application/nps)
2013-04-25 14:07 UTC, Exceptions Reporter
Details
nps snapshot (36.38 KB, application/nps)
2013-06-11 22:52 UTC, Petah
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-04-25 14:07:33 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Windows 7

User Comments:
kosmonaFFFt: Just code...

GUEST: Project properties



Maximum slowness yet reported was 42205 ms, average is 16120
Comment 1 Exceptions Reporter 2013-04-25 14:07:41 UTC
Created attachment 133807 [details]
nps snapshot
Comment 2 Petah 2013-06-11 22:52:36 UTC
Created attachment 135661 [details]
nps snapshot

Slow
Comment 3 Jaroslav Havlin 2013-07-23 12:37:40 UTC
The bug contains slow-code-completion reports caused by java.io.WinNTFileSystem.getBooleanAttributes (or similar I/O methods).

I'm afraid that this cannot be fixed. We cannot make WinNTFileSystem faster.

Tomas, please, if you think it's possible to fix this somehow, in Parsing infrastructure or in Filesystems, please reopen this bug. Thank you.
Comment 4 cwt137 2013-07-24 21:00:52 UTC
Is it really a filesystem issue? I have a SSD and got this problem. Please look at this report: http://statistics.netbeans.org/analytics/detail.do?id=199564
Comment 5 Petah 2013-07-24 21:16:07 UTC
I agree, I have an extremely fast system, so I don't see how this can be a hardware or Windows issue.

42 seconds to open a file is ridiculous, and when I monitor my IO its not even under load.
Comment 6 Jaroslav Havlin 2013-07-25 07:33:50 UTC
(In reply to comment #4)
> Is it really a filesystem issue? I have a SSD and got this problem.
Very probably yes. Most time is spent in java.io.WinNTFileSystem.getBooleanAttributes. All reports come from Windows OS. Your hard drive can be fast, but the filesystem (NTFS) is quite slow sometimes.

(In reply to comment #5)
> 42 seconds to open a file is ridiculous, and when I monitor my IO its not even
> under load.
But the problem that this bug describes is slow code completion, not opening of a file. Are we talking about the same issue?
Comment 7 Petah 2013-07-25 21:36:23 UTC
Why does code completion require accessing NTFS?
Comment 8 Jaroslav Havlin 2013-07-26 10:09:05 UTC
(In reply to comment #7)
> Why does code completion require accessing NTFS?
It needs to know contents of other files in the project, so some I/O is sometimes necessary.
Tomas, please, if you can provide a better answer, feel free to correct me.
Comment 9 Tomas Zezula 2013-07-26 10:17:46 UTC
Right, the code completion is always invoke in some scope (see JLS 6.3.1) the referenced type(s) in the scope may need to be loaded from class files (either from jar or folders).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo