Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228978 - Breakpoint exists, but is not shown in editor
Breakpoint exists, but is not shown in editor
Status: RESOLVED DUPLICATE of bug 219079
Product: debugger
Classification: Unclassified
Component: Java
7.4
All All
: P3 (vote)
: 7.4
Assigned To: Martin Entlicher
issues@debugger
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-24 22:51 UTC by ecerichter
Modified: 2013-06-10 11:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of the issue. (68.46 KB, image/png)
2013-04-24 22:54 UTC, ecerichter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ecerichter 2013-04-24 22:51:45 UTC
Product Version = NetBeans IDE Dev (Build 201304232301)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

Please, see attached screenshot for reference. Image worth a million words...
Comment 1 ecerichter 2013-04-24 22:53:28 UTC
Seems that it started with DEV 201304212301.
The screenshot if from 201304232301.
Comment 2 ecerichter 2013-04-24 22:54:15 UTC
Created attachment 133779 [details]
Screenshot of the issue.
Comment 3 Jiri Kovalsky 2013-04-25 08:41:32 UTC
If you say started, you mean that in the previous build you can toggle line breakpoints normally while since 4/21 you toggle line breakpoints and these don't show up in Editor's gutter?
Comment 4 ecerichter 2013-04-25 11:05:22 UTC
(In reply to comment #3)
> If you say started, you mean that in the previous build you can toggle line
> breakpoints normally while since 4/21 you toggle line breakpoints and these
> don't show up in Editor's gutter?

Yes, and no.

In previous build (4/21) I was able to mark and unmark breakpoints in editor's gutter.

Now, I can mark, but when I unmark, the breakpoint is not removed (but it is only visible in Breakpoints window, not in editor's gutter).
Comment 5 Jiri Kovalsky 2013-04-25 11:58:33 UTC
I see, but is this 100% reproducible for you? I tried it in today's build #201304242301 and I can toggle breakpoints as I want.
Comment 6 Martin Entlicher 2013-05-23 08:25:42 UTC
I'm not able to reproduce this as well. Some concrete steps to reproduce, starting from a fresh user dir, would help.
Comment 7 Martin Entlicher 2013-06-10 11:59:22 UTC
This is actually a duplicate of issue #219079.

*** This bug has been marked as a duplicate of bug 219079 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo