Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228974 - NullPointerException at org.openide.filesystems.FileUtil.toFile
NullPointerException at org.openide.filesystems.FileUtil.toFile
Status: RESOLVED WORKSFORME
Product: php
Classification: Unclassified
Component: Project
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Tomas Mysik
issues@php
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-24 19:07 UTC by Selpi
Modified: 2013-05-23 04:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.38 KB, text/plain)
2013-04-24 19:07 UTC, Selpi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Selpi 2013-04-24 19:07:32 UTC
Build: NetBeans IDE 7.3.1 (Build 201304162201)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.21-b01, Java(TM) SE Runtime Environment, 1.7.0_21-b11
OS: Linux

User Comments:
Selpi: Tried to add symphony framework support for new php project

GUEST: Aparecio el mensaje al tratar de elegit las opciones de php




Stacktrace: 
java.lang.NullPointerException
   at org.openide.filesystems.FileUtil.toFile(FileUtil.java:813)
   at org.netbeans.modules.php.project.ui.customizer.RunAsScript.createRunConfig(RunAsScript.java:222)
   at org.netbeans.modules.php.project.ui.customizer.RunAsScript.validateFields(RunAsScript.java:216)
   at org.netbeans.modules.php.project.ui.customizer.RunAsPanel$InsidePanel$TextFieldUpdater.processUpdate(RunAsPanel.java:247)
   at org.netbeans.modules.php.project.ui.customizer.RunAsScript$FieldUpdater.processUpdate(RunAsScript.java:249)
   at org.netbeans.modules.php.project.ui.customizer.RunAsPanel$InsidePanel$TextFieldUpdater.insertUpdate(RunAsPanel.java:226)
Comment 1 Selpi 2013-04-24 19:07:33 UTC
Created attachment 133774 [details]
stacktrace
Comment 2 Selpi 2013-04-24 22:34:49 UTC
Symphony location hasn't been set in Options before new php project creation attempt.
Comment 3 Tomas Mysik 2013-05-21 09:46:29 UTC
From the stacktrace, it seems that your project is corrupted (does not have valid Source Files). This should be already handled - can you reproduce this issue in the development version of NetBeans [1]?

Thanks.
[1] http://bits.netbeans.org/download/trunk/nightly/latest/
Comment 4 Selpi 2013-05-21 09:58:06 UTC
(In reply to comment #3)
> From the stacktrace, it seems that your project is corrupted (does not have
> valid Source Files). This should be already handled - can you reproduce this
> issue in the development version of NetBeans [1]?
> 
> Thanks.
> [1] http://bits.netbeans.org/download/trunk/nightly/latest/

Well, it was just a newly created php project for PHP Sanity testing.

I'll try to reproduce the problem again with both 7.3.1 RC 201305162200 and nightly build later today.
Comment 5 Tomas Mysik 2013-05-21 11:43:35 UTC
That would be perfect, thanks a lot.
Comment 6 Selpi 2013-05-22 17:48:46 UTC
(In reply to comment #5)
> That would be perfect, thanks a lot.

So, I can't reproduce it neither with NetBeans IDE Dev (Build 201305212300) nor with 7.3.1 RC (Build 201305162200).
Comment 7 Tomas Mysik 2013-05-23 04:38:48 UTC
Thanks a lot for the information.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo