Bug 228738 - Installer says "GlassFish 4.0 is an implementation of Java EE 6"
Installer says "GlassFish 4.0 is an implementation of Java EE 6"
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: Code
7.3.1
PC Windows 7 x64
: P3 (vote)
: 7.3.1
Assigned To: Jiri Rechtacek
issues@installer
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-19 02:01 UTC by ban.nobuhiro
Modified: 2013-05-13 09:12 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ban.nobuhiro 2013-04-19 02:01:03 UTC
I tried nightly build 201304172301. (to check the fix of bug #227745)

On the first step of install, I saw the description about GlassFish 4.0 runtime:

> GlassFish Server Open Source Edition 4.0 is the latest release of
> the GlassFish Application Server, is a compliant implementation of
> the Java EE 6 platform, and features a modular, lightweight and
> extensible architecture.

I think this should be "Java EE 7 platform".
Comment 1 Jiri Rechtacek 2013-04-19 09:26:30 UTC
Thanks for the report. Fixed - http://hg.netbeans.org/core-main/rev/22c03465ba5c

Petr, please review before backporting to NB731. Thanks
Comment 2 Petr Jiricka 2013-04-19 09:44:14 UTC
Thanks - though why not just change EE 6 to EE 7 in the text? The new wording sounds quite buzzword-ey.

Cc'ing also Ken for his opinion.
Comment 3 Petr Jiricka 2013-04-19 09:45:22 UTC
OTOH I agree with leaving out "Open Source Edition".
Comment 4 Quality Engineering 2013-04-21 02:19:07 UTC
Integrated into 'main-golden', will be available in build *201304202301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/22c03465ba5c
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #228738 - Installer says "GlassFish 4.0 is an implementation of Java EE 6"
Comment 5 ban.nobuhiro 2013-04-21 14:24:06 UTC
Thank you for fixing.

Because Japanese description about GlassFish 4.0 was not updated yet,
(I'm using Japanese language on Windows)
I tried nightly build 201304202301 with specifying en:US locale:

> netbeans-trunk-nightly-201304202301-windows.exe --locale en:US

I confirmed that the description is updated, but there are
some mojibake's (unreadable characters) after "Java".

>Javaâ„¢ Platform Enterprise Edition

According to http://hg.netbeans.org/core-main/rev/22c03465ba5c,
This is from "Java\u2122 Platform Enterprise Edition".
I guess: "TM" (UTF16BE)2122 -> (UTF8) e2 84 a2 -> (windows1252)"â„¢".

Is this an environment-dependent problem?
(Again, I'm using Windows 7 Japanese version.)
Comment 6 Jiri Rechtacek 2013-04-21 17:55:00 UTC
(In reply to comment #5)
> Thank you for fixing.
> 
> Because Japanese description about GlassFish 4.0 was not updated yet,
> (I'm using Japanese language on Windows)
> I tried nightly build 201304202301 with specifying en:US locale:
Right, localization might have a slip for while.
> 
> > netbeans-trunk-nightly-201304202301-windows.exe --locale en:US
> 
> I confirmed that the description is updated, but there are
> some mojibake's (unreadable characters) after "Java".
Fixed - http://hg.netbeans.org/core-main/rev/513540003545
There were some wrong characters. Thanks for catching it.

 
> 
> >Javaâ„¢ Platform Enterprise Edition
> 
> According to http://hg.netbeans.org/core-main/rev/22c03465ba5c,
> This is from "Java\u2122 Platform Enterprise Edition".
> I guess: "TM" (UTF16BE)2122 -> (UTF8) e2 84 a2 -> (windows1252)"â„¢".
> 
> Is this an environment-dependent problem?
> (Again, I'm using Windows 7 Japanese version.)
Comment 7 Jiri Rechtacek 2013-04-23 10:03:19 UTC
release73 - http://hg.netbeans.org/releases/rev/6bba53a35992
Comment 8 Quality Engineering 2013-04-24 00:09:13 UTC
Integrated into 'releases', will be available in build *201304232201* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/6bba53a35992
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #228738 - Installer says "GlassFish 4.0 is an implementation of Java EE 6"; backport from trunk


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo