Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228719 - JavaFx project properties - Set configuration does not take effect
JavaFx project properties - Set configuration does not take effect
Status: RESOLVED WORKSFORME
Product: javafx
Classification: Unclassified
Component: Project
7.3.1
PC Windows XP
: P3 (vote)
: TBD
Assigned To: Petr Somol
issues@javafx
:
Depends on: 205367
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 16:38 UTC by lehel
Modified: 2013-09-03 15:34 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Javafx Proiect properties settings (1.47 MB, image/bmp)
2013-05-21 10:05 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2013-04-18 16:38:19 UTC
Product Version = NetBeans IDE 7.3.1 (Build 201304162201)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_21
Runtime = Java HotSpot(TM) Client VM 23.21-b01

I created a new JavaFx Hello World project and I have tested running in browser.
Clicking on the "Project Properties - Set Configuration - Run_in_Browser" does not take effect, running the application with this setting, still results to desktop mode running(standalone).
Comment 1 lehel 2013-04-18 17:05:25 UTC
This is not true at JavaFx FXML applications
Comment 2 lehel 2013-04-18 19:24:44 UTC
This error appears every time when I change the default borwser from Netbeans menu - Tools-Options - for ex. to chrome, and after then trying to set the configuration from <default_config> to Run_in_Browser in Project Properties right click and Set config.
Comment 3 lehel 2013-05-21 10:05:36 UTC
Created attachment 134667 [details]
Javafx Proiect properties settings

Here, in the picture below, the "Manage" button, does not work as i
would expected. I mean choosing a browser with "Manage" button does not
take its effect, still remains the pre-chosen Chrome browser
Comment 4 John Jullion-ceccarelli 2013-05-21 12:35:50 UTC
Honza is on vacation. Petr G, can you follow up?
Comment 5 Marian Mirilovic 2013-05-21 13:13:53 UTC
(In reply to comment #4)
> Honza is on vacation. Petr G, can you follow up?
Incorrect issue ... sorry
Comment 6 Lou Dasaro 2013-09-02 06:23:51 UTC
I am unable to duplicate this error with NB 7.3.1 or 7.4 20130902
I can switch browsers with no problem -
(although I'm having trouble getting Firefox to run it)
Comment 7 Roman Svitanic 2013-09-03 15:34:41 UTC
(In reply to mr_lou_d from comment #6)
> I am unable to duplicate this error with NB 7.3.1 or 7.4 20130902
> I can switch browsers with no problem -
> (although I'm having trouble getting Firefox to run it)

Thanks for verification, I'm also unable to reproduce the issue.
Regarding Firefox 23: it had a bug (https://bugzilla.mozilla.org/show_bug.cgi?id=902375)

lehel: Please make sure that you have in configuration combobox in toolbar selected correct configuration (and in project's settings correct behavior for that configuration). If the issue will persist on the latest dev build (and clean userdir), please reopen with updated/more detailed information how to reproduce the issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo