Bug 228689 - The directory does not seem to be the Grails home directory
The directory does not seem to be the Grails home directory
Status: RESOLVED INVALID
Product: groovy
Classification: Unclassified
Component: Grails
7.3.1
PC Windows 7
: P1 (vote)
: TBD
Assigned To: Martin Janicek
issues@groovy
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 09:31 UTC by MackSix
Modified: 2013-04-22 15:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
logfile (51.61 KB, text/plain)
2013-04-18 09:31 UTC, MackSix
Details
screenshot (87.60 KB, image/png)
2013-04-18 09:35 UTC, MackSix
Details
logfile from 7.3.1 (Build 201304162201) (75.11 KB, text/plain)
2013-04-18 16:11 UTC, MackSix
Details
No NPE logfile from 7.3.1 (Build 201304162201) (52.12 KB, text/plain)
2013-04-18 17:00 UTC, MackSix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2013-04-18 09:31:49 UTC
Created attachment 133555 [details]
logfile

I never had this problem before. I just installed the latest Dev Nightly and occasionally get this message, even when I am not viewing the Groovy panel.

"The directory does not seem to be the Grails home directory"

There is a NPE in the log which might be helping to cause this:

java.lang.NullPointerException
	at org.netbeans.modules.diff.options.DiffOptionsController.isChanged(DiffOptionsController.java:122)


There seems to be a bevy of NPEs going on in the option panel. This is the 4th one I have seen and they all but this NPE has been reported so far. I have seen NPE when viewing the Diff Panel before on the latest Dev Nightly builds.

See attachments.
Comment 1 MackSix 2013-04-18 09:35:16 UTC
Created attachment 133557 [details]
screenshot
Comment 2 MackSix 2013-04-18 16:10:12 UTC
I just got this in 7.3.1 Dev.

See attached log.

Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 3 MackSix 2013-04-18 16:11:29 UTC
Created attachment 133573 [details]
logfile from 7.3.1 (Build 201304162201)
Comment 4 MackSix 2013-04-18 16:46:51 UTC
I can't create a new Grails Application or run and existing one. It says that GRAILS_HOME has not been set, but it is set and works fine in v7.3.

I don't know a workaround.

Regression. P1.
Comment 5 MackSix 2013-04-18 16:59:25 UTC
I don't think the NPEs in the log files have anything to do with it because I don't see any of them if I just start NetBeans up and go to the Groovy Options Pane or try to create a new Grails project. 

I attached a new logfile without all the NPEs.
Comment 6 MackSix 2013-04-18 17:00:49 UTC
Created attachment 133575 [details]
No NPE logfile from 7.3.1 (Build 201304162201)
Comment 7 MackSix 2013-04-18 20:29:50 UTC
FYI: This report started against 7.4: 

Product Version: NetBeans IDE Dev (Build 201304172301)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

The first log file posted is this version, then I moved it back to 7.3.1. Just so nobody gets confused.
Comment 8 Vladimir Riha 2013-04-19 18:40:50 UTC
MackSix, so you did reproduce it in 7.3.1? Is it always reproducible?

I tried 7.3.1 build, created 2 Grails projects, restarted IDE, ran 1 Grails project and then created another Grails project and without any NPE. The same with Options dialog. I got you dialog once only once I set Grails Home dir to point to invalid dir

I can try Windows 7 and Dev on Monday. 




Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
Java: 1.7.0_11; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Linux version 3.5.0-27-generic running on amd64; UTF-8; en_US (nb)
Comment 9 MackSix 2013-04-19 19:34:05 UTC
(In reply to comment #8)

Yep, it does it in 7.3.1 always.
Comment 10 Vladimir Riha 2013-04-22 14:45:21 UTC
Sorry, I still can't reproduce it

Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
Java: 1.7.0_11; Java HotSpot(TM) Client VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)
Comment 11 MackSix 2013-04-22 15:02:56 UTC
(In reply to comment #10)
> Sorry, I still can't reproduce it
> 
> Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
> Java: 1.7.0_11; Java HotSpot(TM) Client VM 23.6-b04
> Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
> System: Windows 7 version 6.1 running on x86; Cp1252; en_US (nb)


Hmmm... I found out if I import setting from 7.3 that has the same path into 7.3.1 it works. It only fails when it is an install of 7.3.1 without importing any settings. Also I am using the full Windows install with "Features on Demand" activation if that makes any difference.
Comment 12 MackSix 2013-04-22 15:55:48 UTC
I looked at my GRAILS_HOME several times and it looked right and it was grails-2.0.0 instead of grails-2.2.0... I should not set this far back from the screen. 

I just uninstalled and reinstalled NetBeans 4 times, different versions and different JDKs and finally saw the problem. 

Sorry for the mistake... 

Resolved.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo