Bug 228670 - Infinity creating file with name uigesture*******.html
Infinity creating file with name uigesture*******.html
Status: RESOLVED FIXED
Product: ide
Classification: Unclassified
Component: Logger
7.3
PC Windows 7 x64
: P1 (vote)
: 7.4
Assigned To: Martin Entlicher
logger-issues@ide
:
: 161691 232000 235730 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-17 16:04 UTC by black_engel
Modified: 2013-10-02 09:12 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
file example (1.32 KB, text/html)
2013-04-17 16:04 UTC, black_engel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description black_engel 2013-04-17 16:04:18 UTC
Created attachment 133542 [details]
file example

hello!

Excuse me, that i select incorrect bug node.

Describe:

I am starting NetBeans IDE Program. It is loading. Then NB When NetBeans Program try to connect to Internet, I am locking (blocking) it access to internet (by FireWall). And NB start creating files infinity  in "..\Windows\Temp\". File Names mask like "uigesture*****.html" (file attached). This Files NetBeans creating all time (when is running). My Windows folder consists more then 200 000 this files, but Program creating files anyway. And Program takes many Processor time.

If it a bug, please write me, when you correct the bug, and i am downloading this version. 
I saw this bug in version 7.2.1, 7.3.
Comment 1 Tomas Mysik 2013-04-22 06:17:56 UTC
Nothing to do with PHP support, reassigning. Please evaluate, thanks.
Comment 2 Martin Entlicher 2013-04-27 07:00:26 UTC
There occurs an error during parsing of this file:
org.xml.sax.SAXParseException; lineNumber: 9; columnNumber: 7; The element type "meta" must be terminated by the matching end-tag "</meta>".
There's a problem in the Russian version of org/netbeans/modules/uihandler/SAXException.html file.
Comment 3 black_engel 2013-04-27 09:16:40 UTC
Please sorry! I am forget notice, that I live in Ukraine. And I am using Russian Version
Comment 4 Martin Entlicher 2013-04-29 12:13:17 UTC
The infinite loop is detected and interrupted by changeset: 252231:f67c6d3bbc1c
http://hg.netbeans.org/core-main/rev/f67c6d3bbc1c
Comment 5 Quality Engineering 2013-05-02 14:11:46 UTC
Integrated into 'main-golden', will be available in build *201305021042* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f67c6d3bbc1c
User: mentlicher@netbeans.org
Log: #228670: Prevent from an infinite loop when the file we're parsing is corrupted.
Comment 6 Martin Entlicher 2013-07-18 12:13:02 UTC
*** Bug 232000 has been marked as a duplicate of this bug. ***
Comment 7 Martin Entlicher 2013-09-10 07:05:34 UTC
*** Bug 235730 has been marked as a duplicate of this bug. ***
Comment 8 nkl 2013-09-19 17:01:28 UTC
I have installed a licensed win2k7pro x64. Antivirus Microsoft Security Essentials. In folder "c:\Users\%username%\AppData\Local\Temp" NetBeans created over 3 million files with name "uigesture*******.html". In the office from time to time there was no Internet. IDE don't load on stage "module loading". A clearing the folder by help me. I turned off the function of sending anonymous statistics and the problem disappeared.
Comment 9 Martin Entlicher 2013-09-20 06:02:37 UTC
nkl, please do not modify the target milestone. Which NetBeans version do you use?
Comment 10 Martin Entlicher 2013-09-20 06:05:12 UTC
Probably an older than 7.4, since you've changed the Target Milestone.
Resolving back as fixed in 7.4. We will not backport the fix into 7.3.1 AFAIK.
Comment 11 Martin Entlicher 2013-10-02 09:12:40 UTC
*** Bug 161691 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo