Bug 228668 - Quick search returns result list. After user's selection in the list, the red 'no results' shows under quick search text field.
Quick search returns result list. After user's selection in the list, the red...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Quick Search
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-17 15:43 UTC by ysgao
Modified: 2013-05-19 02:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (49.93 KB, text/plain)
2013-04-17 15:43 UTC, ysgao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ysgao 2013-04-17 15:43:16 UTC
Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Mac OS X version 10.8.3 running on x86_64
Java; VM; Vendor = 1.6.0_43
Runtime = Java HotSpot(TM) 64-Bit Server VM 20.14-b01-447
Comment 1 ysgao 2013-04-17 15:43:31 UTC
Created attachment 133541 [details]
IDE log
Comment 2 Marian Mirilovic 2013-04-20 07:41:11 UTC

*** This bug has been marked as a duplicate of bug 228156 ***
Comment 3 ysgao 2013-05-13 13:21:03 UTC
I downloaded core-main and built the latest development version of NetBeans. It
does fix the issue for displaying results in proper width with the improved
speed of first search. 

However, the issue raised in bug 228668 has not been fixed yet. The red 'no
results' still shows under quick search after selection of a result from pop-up
result list. Since a list of results have been returned, it should never show
the red 'no results' message. 

Please fix this issue. Let me know if any further information is needed. 

Many thanks! 

-----------
Product Version = NetBeans IDE Dev (Build 20130510-22736c60e10d)
Operating System = Mac OS X version 10.8.3 running on x86_64
Java; VM; Vendor = 1.7.0_10
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Comment 4 Marian Mirilovic 2013-05-16 07:59:01 UTC
(In reply to comment #3)
> Please fix this issue. Let me know if any further information is needed. 

Please provide exact steps to reproduce and reopen. Thanks in advance !
Comment 5 ysgao 2013-05-16 18:03:47 UTC
Hi, 

Many thanks for your quick response. It is quite easy to reproduce the problem without writing codes.

First, create a new NetBeans Platform application from wizard. Then add a new module and a window from wizard. It gives you the default built-in quick search. 

If you do a quick search, it will privide a list of results for built-in actions or options. After selecting a result from the list, you will see the red "(no results)" message.

My application has implementation for the quick search. It does show the search results. The selection also works for the result list. So it is the same problem as the above quick interface build demonstrated.

Any solutions or workaround will be much appreciated.

Kind regards,

Yong
Comment 6 Jaroslav Havlin 2013-05-17 12:03:01 UTC
The bug occurs if there is no top component that can own focus, or that doesn't override requestFocus() method appropriately.

Fixed in http://hg.netbeans.org/core-main/rev/bd184b681735
Please verify. Thank you very much for reporting.
Comment 7 ysgao 2013-05-17 17:06:31 UTC
Thank you so much. You have done the magic. I can confirm that the bug is fixed and the red eyesore message is gone :-)
Comment 8 Quality Engineering 2013-05-19 02:53:08 UTC
Integrated into 'main-golden', will be available in build *201305182300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bd184b681735
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #228668: Red 'no results' shown under quick search text field after selection of an item


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo