Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228494 - Extract interface refactoring hangs
Extract interface refactoring hangs
Status: RESOLVED WONTFIX
Product: third-party
Classification: Unclassified
Component: -- Other --
7.3.1
PC Linux
: P1 (vote)
: 7.3.1
Assigned To: issues@third-party
issues@third-party
:
: 229044 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-11 20:09 UTC by fwelland
Modified: 2013-04-26 11:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump of hung extract interface in nb 7.3.1 (54.89 KB, application/octet-stream)
2013-04-12 14:32 UTC, fwelland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fwelland 2013-04-11 20:09:08 UTC
In a Gradle project, I select a class in project explore and right click and do 

Refactor->Extract Interface

Fill out the dialog box (only 5 methods -- 4 are checked for extraction)  provide a name for new Java interface and then hit 'Refactor'   -- Hang. 

Repeat about 10 times  (kill -9 each time)    Then I try 'Preview'   that provides a good display of what NB wants to do -- then I hit refactor -- Hang.   Repeat -- but this time only select "create the new file" -- hang. 

On a kick I try the same thing for "Extract Superclass" -- basically the same -- hang.       Log file in $HOME/.netbeans/7.3/var/log/message.log does or says  nothing.   And yes I have waited 10+ minutes or so  (project really isn't that large -- 300 files maybe).   

----
Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_17; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b02
System: Linux version 3.8.5-201.fc18.x86_64 running on amd64; UTF-8; en_US (nb)
User directory: /home/fwelland/.netbeans/7.3
Cache directory: /home/fwelland/.cache/netbeans/7.3
Comment 1 Jiri Prox 2013-04-12 06:33:58 UTC
Can you please attach thread dump?
Comment 2 fwelland 2013-04-12 14:31:39 UTC
sure.   Attached.    

FWIW:   I issued this the extract interface at about 920 edt;  took the dump at maybe 925edt and left for a meeting.    Still hung at 1031edt  (all am).
Comment 3 fwelland 2013-04-12 14:32:34 UTC
Created attachment 133475 [details]
thread dump of hung extract interface in nb 7.3.1
Comment 4 Ralph Ruijs 2013-04-20 18:43:12 UTC
Deadlock in Gradle's GradleTemplateAttrProvider.
Comment 5 Ralph Ruijs 2013-04-20 18:47:56 UTC
Created issue in upstream project.

https://github.com/kelemen/netbeans-gradle-project/issues/37
Comment 6 Ralph Ruijs 2013-04-26 11:24:21 UTC
*** Bug 229044 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo