Bug 228410 - Authentication fails dialog has no Repository URL
Authentication fails dialog has no Repository URL
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.3.1
PC Mac OS X
: P2 (vote)
: 7.3.1
Assigned To: Ondrej Vrabec
issues@versioncontrol
73patch2-verified
:
: 228596 229228 229394 229959 230513 231102 231169 (view as bug list)
Depends on: 226723
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-09 13:34 UTC by Kenneth Ganfield
Modified: 2013-06-12 18:15 UTC (History)
9 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot of dialog (27.02 KB, image/png)
2013-04-09 13:34 UTC, Kenneth Ganfield
Details
messages log (61.84 KB, application/octet-stream)
2013-04-09 13:46 UTC, Kenneth Ganfield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Ganfield 2013-04-09 13:34:04 UTC
Created attachment 133392 [details]
screenshot of dialog

When trying to commit to a svn repository the dialog displays the Authentication Failed dialog box. Usually I would be prompted to supply the user/pw in this dialog, but the dialog is now empty.

See the attached screenshot.

This works fine in 7.3 so marking as regression.
Comment 1 Ondrej Vrabec 2013-04-09 13:36:34 UTC
Please attach the messages.log plus the content of the svn repository's Output Tab
Comment 2 Kenneth Ganfield 2013-04-09 13:46:36 UTC
Created attachment 133393 [details]
messages log

messages log attached.

svn output:


==[IDE]== Apr 9, 2013 3:43:11 PM Updating "trunk"
update /Users/nb/Documents/netbeans_repository/testwww-svn-live/trunk -r HEAD --force
svn: E200015: authentication cancelled
svn: E200015: authentication cancelled
update /Users/nb/Documents/netbeans_repository/testwww-svn-live/trunk -r HEAD --force
svn: E200015: authentication cancelled
svn: E200015: authentication cancelled
svn: E200015: authentication cancelled
==[IDE]== Apr 9, 2013 3:44:19 PM Updating "trunk" finished.
Comment 3 Ondrej Vrabec 2013-04-09 13:53:44 UTC
seems to be a race condition introduced by the fox for bug #226723
Comment 4 Ondrej Vrabec 2013-04-09 14:04:03 UTC
fix: http://hg.netbeans.org/core-main/rev/33cde6e80d09
Comment 5 Ondrej Vrabec 2013-04-16 08:00:07 UTC
*** Bug 228596 has been marked as a duplicate of this bug. ***
Comment 6 rockorequin 2013-04-18 05:36:38 UTC
FYI, I'm seeing this in 7.3 as well on an Ubuntu system (ie the regression occurred before 7.3.1 for me).

I installed 7.3 and opened an existing project, and the Subversion Manage Connection Settings window has no URLs. Hopefully it's the same bug and this bugfix will fix my issue.
Comment 7 Ondrej Vrabec 2013-04-18 05:50:15 UTC
> I installed 7.3 and opened an existing project, and the Subversion Manage
> Connection Settings window has no URLs.
> Hopefully it's the same bug and this bugfix will fix my issue.
I don't think so. You're problem is simply that you have no connections saved/stored so there is nothing to show there. Once you perform update/commit and fill in the credentials, the combo will be populated.
Comment 8 Kenneth Ganfield 2013-04-18 11:55:16 UTC
Reopening because I am still seeing this behavior.

Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
Comment 9 Kenneth Ganfield 2013-04-18 11:57:02 UTC
It seems to be intermittent.
The dialog displays the repo url properly 1 out of 10 times.
Comment 10 Ondrej Vrabec 2013-04-18 12:02:18 UTC
> Reopening because I am still seeing this behavior.
> Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
What version are you able to reproduced this in (7.3.1 or dev build 201304162201)? The fix has not been transplanted to 7.3.1 yet, it's been fixed only in dev.
Comment 11 Kenneth Ganfield 2013-04-18 12:04:39 UTC
(In reply to comment #10)
> > Reopening because I am still seeing this behavior.
> > Product Version: NetBeans IDE 7.3.1 (Build 201304162201)
> What version are you able to reproduced this in (7.3.1 or dev build
> 201304162201)? The fix has not been transplanted to 7.3.1 yet, it's been fixed
> only in dev.

7.3.1 build
Comment 12 Ondrej Vrabec 2013-04-18 12:08:43 UTC
stepan, can you verify in trunk so i can transplant into 7.3.1?
Comment 13 Stepan Zebra 2013-04-19 10:32:40 UTC
verified in trunk
Comment 14 Ondrej Vrabec 2013-04-23 10:44:57 UTC
http://hg.netbeans.org/releases/rev/5ba24321c1db
Comment 15 Quality Engineering 2013-04-24 00:09:08 UTC
Integrated into 'releases', will be available in build *201304232201* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/5ba24321c1db
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #228410 - Authentication fails dialog has no Repository URL
model should be updated in AWT
(transplanted from 33cde6e80d09f70235a4a945a4d35db6cbd03ca4)
Comment 16 Ondrej Vrabec 2013-04-30 15:04:06 UTC
*** Bug 229228 has been marked as a duplicate of this bug. ***
Comment 17 masterblah777 2013-04-30 15:05:55 UTC
When can we expect a fixed build to be released?
Comment 18 Stepan Zebra 2013-05-02 12:40:05 UTC
(In reply to comment #17)
> When can we expect a fixed build to be released?

please see current schedule at http://wiki.netbeans.org/NetBeansPatchesProcess

In the meantime, the dialog should eventually show up correctly if you hit Retry button on it for a few times.
Comment 19 Ondrej Vrabec 2013-05-09 07:57:44 UTC
*** Bug 229394 has been marked as a duplicate of this bug. ***
Comment 20 Stepan Zebra 2013-05-10 09:43:33 UTC
verified in 7.3.1
Comment 21 Ondrej Vrabec 2013-05-19 14:03:19 UTC
*** Bug 229959 has been marked as a duplicate of this bug. ***
Comment 22 Jan Peska 2013-05-30 14:07:20 UTC
*** Bug 230513 has been marked as a duplicate of this bug. ***
Comment 23 Ondrej Vrabec 2013-06-11 19:35:22 UTC
*** Bug 231102 has been marked as a duplicate of this bug. ***
Comment 24 Ondrej Vrabec 2013-06-12 18:15:47 UTC
*** Bug 231169 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo