Bug 228394 - cannot add JBoss AS 7.2.0
cannot add JBoss AS 7.2.0
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: JBoss
7.3.1
PC Linux
: P3 (vote)
: 7.3.1
Assigned To: Petr Hejl
issues@serverplugins
73patch2-verified
:
: 226594 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-08 22:10 UTC by cheesus
Modified: 2013-05-09 13:40 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cheesus 2013-04-08 22:10:35 UTC
Failed to add the new JBoss AS 7.2.0.Final with NPE below.
(AS 7.1.1 works)
Looks related to #226591, but error in a different line.

java.lang.NullPointerException
        at org.netbeans.modules.j2ee.jboss4.ide.ui.JBPluginUtils.getRegisteredDomains(JBPluginUtils.java:300)
        at org.netbeans.modules.j2ee.jboss4.ide.ui.AddServerPropertiesVisualPanel.init(AddServerPropertiesVisualPanel.java:229)
        at org.netbeans.modules.j2ee.jboss4.ide.ui.AddServerPropertiesVisualPanel.<init>(AddServerPropertiesVisualPanel.java:97)
        at org.netbeans.modules.j2ee.jboss4.ide.ui.AddServerPropertiesPanel.getComponent(AddServerPropertiesPanel.java:166)
        at org.netbeans.modules.j2ee.jboss4.ide.ui.JBInstantiatingIterator.current(JBInstantiatingIterator.java:262)
        at org.netbeans.modules.j2ee.deployment.impl.bridge.BridgingServerWizardProvider$InstantiatingIteratorBridge.current(BridgingServerWizardProvider.java:151)
        at org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard$AddServerInstanceWizardIterator.current(AddServerInstanceWizard.java:346)
        at org.openide.WizardDescriptor.updateStateOpen(WizardDescriptor.java:842)
        at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:820)
        at org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard.updateState(AddServerInstanceWizard.java:238)
        at org.openide.WizardDescriptor._updateState(WizardDescriptor.java:798)
        at org.openide.WizardDescriptor.goToNextStep(WizardDescriptor.java:1070)
        at org.openide.WizardDescriptor.access$1800(WizardDescriptor.java:90)
        at org.openide.WizardDescriptor$Listener$1.run(WizardDescriptor.java:2132)
        at org.openide.WizardDescriptor.lazyValidate(WizardDescriptor.java:1512)
        at org.openide.WizardDescriptor.access$1900(WizardDescriptor.java:90)
        at org.openide.WizardDescriptor$Listener.actionPerformed(WizardDescriptor.java:2151)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:601)
        at org.openide.util.WeakListenerImpl$ProxyListener.invoke(WeakListenerImpl.java:457)
        at sun.proxy.$Proxy48.actionPerformed(Unknown Source)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
        at java.awt.Component.processMouseEvent(Component.java:6505)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)


Note: JBoss no longer provides binaries for the OSS versions. You need to download 7.2.0.Final from github and call build.sh
https://github.com/jbossas/jboss-as/tree/7.2.0.Final
(If you also think this is uncool, complain to JBoss. Currently there seems to be little resistance to that change...)

Due to some bug, either build the dist above with -DskipTests, or use this fix:
https://github.com/jaikiran/jboss-as/tree/7.2.0.Final-testsuite-fix


Product Version: NetBeans IDE Dev (Build 201304042355)
Java: 1.7.0_13; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_13-b20
System: Linux version 2.6.37.6-24-desktop running on amd64; UTF-8; de_DE (nb)
Comment 1 cheesus 2013-04-08 22:27:32 UTC
Looking at the JBPluginUtils, it is looking in a directory
  modules/org/jboss/as/server/main
which is now 
  modules/system/layers/base/org/jboss/as/server/main

Thinking about this, would it not be better to call "bin/standalone.sh -v" ?

Or if that is out of the question, just "any" (the first) jar in "modules" ?
see: https://issues.jboss.org/browse/AS7-2661
Comment 2 Petr Hejl 2013-04-09 10:36:59 UTC
Should be fixed in web-main 7db6b7c820bd. Please verify.

I don't really understand why JBoss is changing things with every minor release.

Mariane, should I put it also to 7.3.1 where is the JBoss 7 available for the first time? It would need at least some basic sanity testing I guess.
Comment 3 Marian Mirilovic 2013-04-09 13:33:35 UTC
(In reply to comment #2)
> Should be fixed in web-main 7db6b7c820bd. Please verify.
> 
> I don't really understand why JBoss is changing things with every minor
> release.
> 
> Mariane, should I put it also to 7.3.1 where is the JBoss 7 available for the
> first time? It would need at least some basic sanity testing I guess.

I think so, we will do so ... please do not forget to mention this in New and Noteworthy for 7.3.1, thanks in advance.
Comment 4 Petr Hejl 2013-04-10 09:35:33 UTC
Classpath fix web-main f0b902f07189. I'm going to transplant changesets to 7.3.1.
Comment 5 Petr Hejl 2013-04-10 10:19:34 UTC
Transplanted to javaee7 branch e4215e72e09b and 20c58b141217.
Comment 6 Petr Hejl 2013-04-15 11:31:13 UTC
*** Bug 226594 has been marked as a duplicate of this bug. ***
Comment 7 Jiri Skrivanek 2013-04-16 13:26:27 UTC
Verified it is possible to register JBoss 7.2.0. But deploymwnt is broken for me (see bug 228619).
Comment 8 Marian Mirilovic 2013-05-03 11:15:41 UTC
So, where exactly is this issue fixed ? Is it already in release73 repository ?
If so, please change SW to '73patch2-fixed',
If not, please backport the fix into release73 ASAP 

Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo