Bug 228358 - Created Maven EE7 web project contains outdated javaee-web-api jar
Created Maven EE7 web project contains outdated javaee-web-api jar
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
7.3.1
All All
: P3 (vote)
: 7.3.1
Assigned To: Martin Janicek
issues@javaee
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-08 07:14 UTC by Martin Fousek
Modified: 2013-05-09 13:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Fousek 2013-04-08 07:14:00 UTC
1, I created new Maven JavaEE 7 Web Application.
2, It contains javaee-web-api-7.0-b78.jar in it's dependencies
-> this JARs looks to me very outdated since the bundled javax.faces API is of version 2.1

Could you please update it to the latest one? Thanks...
Comment 1 Martin Janicek 2013-04-08 08:31:24 UTC
I've send archetype patch to Milos. I'll increase the version used in project wizard once the archetypes will be updated.
Comment 2 Martin Janicek 2013-04-11 09:26:34 UTC
Fixed in: web-main #1e2ef6df3668 (javaee7 branch)
Comment 3 Jiri Skrivanek 2013-04-16 12:59:35 UTC
Current javaee-web-api version in maven project is 7.0-b83 which is correct as I suppose.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo