Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228316 - JPQL CC doesn't work on multi-line queries/queries with "+" concatenation
JPQL CC doesn't work on multi-line queries/queries with "+" concatenation
Status: RESOLVED DUPLICATE of bug 212951
Product: javaee
Classification: Unclassified
Component: Persistence
7.4
PC Mac OS X
: P3 (vote)
: TBD
Assigned To: Sergey Petrov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-05 23:12 UTC by athompson
Modified: 2013-09-06 11:37 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description athompson 2013-04-05 23:12:48 UTC
It's understandable if CC doesn't work after concatenating a non-literal to a JPQL string, but simple "+" concatenation of literals (for example when breaking up a long JQPL query into multiple lines) should not affect CC.
Comment 1 athompson 2013-04-05 23:17:58 UTC
For example:

    EntityManager em = ...
    Query q = em.createQuery(
        "SELECT e " +
        "FROM MyEntity e " +
        "WHERE e.status.id = 1"
    );

Currently, CC only works on the first line, but there's no reason it should not work on all three lines.
Comment 2 Sergey Petrov 2013-09-06 11:37:43 UTC
yes, it's unsupported

*** This bug has been marked as a duplicate of bug 212951 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo