Bug 228241 - Cursor lost in editor
Cursor lost in editor
Status: RESOLVED INVALID
Product: editor
Classification: Unclassified
Component: Navigation
7.3.1
PC Linux
: P2 (vote)
: TBD
Assigned To: Milutin Kristofic
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-04 09:59 UTC by ihsahn
Modified: 2013-10-22 18:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ihsahn 2013-04-04 09:59:09 UTC
This seems a new reincarnation of bug #119617, I am opening new defect per comment https://netbeans.org/bugzilla/show_bug.cgi?id=119617#c140.

Env:

- netbeans 7.3. netbeans 7.3.1, current dev
- Oracje JDK 1.7 u17 64 bit
- Ubuntu 12.10 with Xfce
- all of the above 64 bit system (64 bit kernel etc)

NB starts, loads project, I can edit file, but as soon as I alt-tab to 
other application and get back.. no keyboard actions are available. I 
mean click on the editor and I see that status bar indicates that curor 
position changed, but there is no cursor, I cannot type anything etc.. I 
may leave NB open and do some other work and after some time when I get 
back cursor is available, but of course when I switch to other 
application for a moment, everything starts again... making it impossible to do any real work.

I've tried following things with no effect:
- Netbeans 6.2
- Jdk 1.7 u 17 32 bit

the only thing that currently works is downgrading jdk to 1.6 so it would
suggest that it's indeed JDK issue, however bug linked in #119617 as root cause is closed long ago....

also, exactly the same configuration, except that running on 32 bit 
system shows no problems.
Comment 1 Milutin Kristofic 2013-04-25 15:47:44 UTC
Can you please try your issue in Notepad.jar?
'java -jar $JAVA_HOME/demo/jfc/Notepad/Notepad.jar'
Comment 2 ihsahn 2013-10-22 18:51:08 UTC
It works right now. It get fixed around update u40. I'm marking this as resolved/invalid then. 

btw: I don't know how this happened but I must missed an email with Milutins comment ;/


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo