Bug 228231 - Inscrutable yes/no dialog on IDE exit
Inscrutable yes/no dialog on IDE exit
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.2.1
PC All
: P3 (vote)
: 8.0
Assigned To: Jaroslav Havlin
issues@platform
:
: 235778 239952 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-04 06:51 UTC by _ tboudreau
Modified: 2014-01-09 14:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen shot (20.88 KB, image/png)
2013-04-04 06:51 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2013-04-04 06:51:22 UTC
Created attachment 133292 [details]
Screen shot

NetBeans was stuck in a never-ending source scan, so I decided to exit the IDE.  Two background activities - "checking for external changes" and "background parsing of source files" were running.

When I tried to exit, I got this strange dialog.  It has Yes and No buttons, but it does not ask any question.  See attached screen shot.
Comment 1 Tomas Zezula 2013-04-04 07:48:54 UTC
The "checking for external changes" has nothing to do with java/project. It's a part of the masterfs.
Comment 2 _ tboudreau 2013-04-04 08:22:53 UTC
Ah, didn't know which background activity actually caused the dialog.
Comment 3 Jaroslav Tulach 2013-07-09 09:59:39 UTC
Possibly just remove the code that shows the dialog completely. Also consider removing Tools/Options/Misc/Files/Auto Scan for Changes checkbox.
Comment 4 Jaroslav Havlin 2013-09-11 12:37:54 UTC
> Possibly just remove the code that shows the dialog completely.
http://hg.netbeans.org/core-main/rev/93676210315e

> Also consider removing Tools/Options/Misc/Files/Auto Scan for Changes checkbox.
I'm leaving the checkbox in the options dialog for now.

Thank you for reporting.
Comment 5 Quality Engineering 2013-09-12 01:22:53 UTC
Integrated into 'main-silver', will be available in build *201309120002* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/93676210315e
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #228231: Inscrutable yes/no dialog on IDE exit
Comment 6 Jaroslav Havlin 2013-09-19 09:32:46 UTC
*** Bug 235778 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Havlin 2014-01-09 14:53:13 UTC
*** Bug 239952 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo