Bug 228202 - Feeds on Start Page not accessible after nb.org migration
Feeds on Start Page not accessible after nb.org migration
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Welcome
7.3
All All
: P1 (vote)
: 7.3.1
Assigned To: Stanislav Aubrecht
issues@ide
73patch2-verified
:
: 230232 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-03 12:45 UTC by Antonin Nebuzelsky
Modified: 2013-05-24 13:20 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2013-04-03 12:45:55 UTC
The following feeds are not displayed in Start Page after the netbeans.org migration which happened last weekend.

* Featured Demo
(netbeans.org/demos.xml)

* News & Tutorials
(netbeans.org/news.xml, netbeans.org/mtmo.xml)

Root cause is that all URL requests at netbeans.org server are redirected to https.
Comment 1 Stanislav Aubrecht 2013-04-03 13:23:17 UTC
A quick hack to accept https connections:

    private static void initSSL( HttpURLConnection httpCon ) throws IOException {
        if( httpCon instanceof HttpsURLConnection ) {
            HttpsURLConnection https = ( HttpsURLConnection ) httpCon;

            try {
                TrustManager[] trustAllCerts = new TrustManager[]{
                    new X509TrustManager() {
                        @Override
                        public X509Certificate[] getAcceptedIssuers() {
                            return new X509Certificate[0];
                        }

                        @Override
                        public void checkClientTrusted( X509Certificate[] certs, String authType ) {
                        }

                        @Override
                        public void checkServerTrusted( X509Certificate[] certs, String authType ) {
                        }
                    } };
                SSLContext sslContext = SSLContext.getInstance( "SSL" ); //NOI18N
                sslContext.init( null, trustAllCerts, new SecureRandom() );
                https.setHostnameVerifier( new HostnameVerifier() {
                    @Override
                    public boolean verify( String hostname, SSLSession session ) {
                        return true;
                    }
                } );
                https.setSSLSocketFactory( sslContext.getSocketFactory() );
            } catch( Exception ex ) {
                throw new IOException( ex );
            }
        }
    }
Comment 2 Stanislav Aubrecht 2013-04-03 13:50:07 UTC
core-main a1e29ab0536a
Comment 3 Stanislav Aubrecht 2013-04-04 13:00:21 UTC
and a fix for the demo image: core-main 68e5fe0fdc6c
Comment 4 Antonin Nebuzelsky 2013-04-05 12:25:45 UTC
keeping track of "73patch2-candidate" in case it needs to be backported to 7.3.1
Comment 5 Tomas Danek 2013-05-02 14:28:20 UTC
Any progress on serverside revert to http?

Fix itself seems to work fine anyway in NetBeans IDE Dev (Build 201304292301)
Comment 6 Antonin Nebuzelsky 2013-05-03 14:29:22 UTC
The server side should change soon to fix this problem for all previous versions.

However, let's backport these changesets to release73 to make sure that 7.3.1 is OK regardless of any future server changes.
Comment 7 Stanislav Aubrecht 2013-05-06 09:54:28 UTC
backported to release73 branch as 793c644a4e9d
Comment 8 Quality Engineering 2013-05-07 00:18:31 UTC
Integrated into 'releases', will be available in build *201305062200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/793c644a4e9d
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #228202 - backport of a1e29ab0536a and 68e5fe0fdc6c
Comment 9 Antonin Nebuzelsky 2013-05-07 11:59:01 UTC
Verified in 7.3.1 build.
Comment 10 Stanislav Aubrecht 2013-05-24 13:20:56 UTC
*** Bug 230232 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo