Bug 228156 - Cannot report exception since nb.org migration
Cannot report exception since nb.org migration
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Exceptions Reporter
7.3
PC Mac OS X
: P1 (vote)
: 7.3.1
Assigned To: Tomas Danek
logger-issues@ide
73patch2-verified
:
: 225694 228115 228118 228123 228134 228136 228147 228159 228211 228220 228247 228268 228272 228354 228385 228392 228454 228463 228513 228613 228615 228666 228681 228713 228718 228724 228757 233028 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-02 12:38 UTC by Tomas Danek
Modified: 2013-07-22 14:57 UTC (History)
28 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2013-04-02 12:38:47 UTC
..and this seems to be the reason

java.lang.ArrayIndexOutOfBoundsException
	at java.lang.System.arraycopy(Native Method)
	at java.io.PushbackInputStream.unread(PushbackInputStream.java:235)
	at org.netbeans.modules.uihandler.Installer.copyWithEncoding(Installer.java:1458)
	at org.netbeans.modules.uihandler.Installer$Submit.doShow(Installer.java:1634)
	at org.netbeans.modules.uihandler.Installer.displaySummary(Installer.java:1001)
	at org.netbeans.modules.uihandler.Installer.displaySummary(Installer.java:1010)
	at org.netbeans.modules.uihandler.UIHandler.run(UIHandler.java:219)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1432)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2044)
Comment 1 Tomas Danek 2013-04-02 13:41:48 UTC
seems like after migration, everything on nb.org site must be accessed via https;  
nb-core-imac1:tmp tomas$ curl -O "http://netbeans.org/index.html"
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
nb-core-imac1:tmp tomas$ curl -O "https://netbeans.org/index.html"
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 16367    0 16367    0     0  12017      0 --:--:--  0:00:01 --:--:-- 18493
nb-core-imac1:tmp tomas$
Comment 2 Tomas Danek 2013-04-02 13:50:40 UTC
fixed in core-main#045b0e0f34a5
Comment 3 Tomas Danek 2013-04-02 13:51:50 UTC
*** Bug 228123 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Danek 2013-04-03 12:03:51 UTC
*** Bug 228118 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Danek 2013-04-04 12:14:54 UTC
*** Bug 228247 has been marked as a duplicate of this bug. ***
Comment 6 Marian Mirilovic 2013-04-05 08:42:42 UTC
*** Bug 228115 has been marked as a duplicate of this bug. ***
Comment 7 Marian Mirilovic 2013-04-05 08:42:57 UTC
*** Bug 228220 has been marked as a duplicate of this bug. ***
Comment 8 Marian Mirilovic 2013-04-05 09:00:40 UTC
*** Bug 228147 has been marked as a duplicate of this bug. ***
Comment 9 Marian Mirilovic 2013-04-05 09:00:50 UTC
*** Bug 228159 has been marked as a duplicate of this bug. ***
Comment 10 Marian Mirilovic 2013-04-05 10:00:52 UTC
*** Bug 228272 has been marked as a duplicate of this bug. ***
Comment 11 Marian Mirilovic 2013-04-05 10:01:09 UTC
*** Bug 228268 has been marked as a duplicate of this bug. ***
Comment 12 Marian Mirilovic 2013-04-05 10:02:02 UTC
*** Bug 228134 has been marked as a duplicate of this bug. ***
Comment 13 Marian Mirilovic 2013-04-05 10:02:24 UTC
*** Bug 228136 has been marked as a duplicate of this bug. ***
Comment 14 Antonin Nebuzelsky 2013-04-05 12:26:13 UTC
keeping track of "73patch2-candidate" in case it needs to be backported to 7.3.1
Comment 15 Tomas Danek 2013-04-06 07:54:49 UTC
*** Bug 228211 has been marked as a duplicate of this bug. ***
Comment 16 Marian Mirilovic 2013-04-08 06:15:01 UTC
*** Bug 228354 has been marked as a duplicate of this bug. ***
Comment 17 Marian Mirilovic 2013-04-09 08:23:52 UTC
*** Bug 228392 has been marked as a duplicate of this bug. ***
Comment 18 Tomas Danek 2013-04-09 09:02:08 UTC
*** Bug 228385 has been marked as a duplicate of this bug. ***
Comment 19 Tomas Danek 2013-04-10 15:09:01 UTC
I'm going to make more robust fix that we could include in patch/7.3.1 (just for case https will be reverted back to http)
Comment 20 Tomas Danek 2013-04-10 19:38:50 UTC
*** Bug 228454 has been marked as a duplicate of this bug. ***
Comment 21 Marian Mirilovic 2013-04-11 08:11:02 UTC
*** Bug 228463 has been marked as a duplicate of this bug. ***
Comment 22 Tomas Danek 2013-04-15 11:08:36 UTC
Fixed more robustly in core-main by 916fc7cbee61 and 9b3289a81d3d
Comment 23 Tomas Danek 2013-04-16 12:12:15 UTC
*** Bug 228615 has been marked as a duplicate of this bug. ***
Comment 24 Tomas Danek 2013-04-16 16:33:07 UTC
*** Bug 228613 has been marked as a duplicate of this bug. ***
Comment 25 jlownie 2013-04-18 04:17:32 UTC
This issue also affects 7.2.1.  Is there anything that can be done about that (patch, etc)?
Comment 26 Tomas Danek 2013-04-18 08:21:44 UTC
*** Bug 228666 has been marked as a duplicate of this bug. ***
Comment 27 Tomas Danek 2013-04-18 08:24:55 UTC
Current status is that issue is resolved in recent dev builds; for already released versions we are trying to push forward server-side solution, which would affect all versions, rather than patching version by version.
Please stay tuned for updates.
 
(In reply to comment #25)
> This issue also affects 7.2.1.  Is there anything that can be done about that
> (patch, etc)?
Comment 28 misterm 2013-04-18 12:05:52 UTC
I still cannot report slowness using 20130408-f130a8702c06. Wasn't it supposed to work?
Comment 29 Tomas Danek 2013-04-18 13:13:29 UTC
Unfortunately no, this fix just gets rid of AIOOBE thrown during report, reporting itself still does not work due to missing webservice after netbeans.org migration :(
(In reply to comment #28)
> I still cannot report slowness using 20130408-f130a8702c06. Wasn't it supposed
> to work?
Comment 30 misterm 2013-04-18 13:16:49 UTC
(In reply to comment #29)
> Unfortunately no, this fix just gets rid of AIOOBE thrown during report,
> reporting itself still does not work due to missing webservice after
> netbeans.org migration :(

So what is the issue number for slowness reports being broken? I had reported one and it was closed as a duplicate of this one!
Comment 31 Tomas Danek 2013-04-18 14:41:07 UTC
Reporting does not work for two particular problems - one is fixed in code (status FIXED), the other is pending (will not be fixed in code, but by internal infrastr. setup). Both are tracked under this issue; I'll post an update to this issue once reporting infrastructure will be back again. 

(In reply to comment #30)
> (In reply to comment #29)
> > Unfortunately no, this fix just gets rid of AIOOBE thrown during report,
> > reporting itself still does not work due to missing webservice after
> > netbeans.org migration :(
> 
> So what is the issue number for slowness reports being broken? I had reported
> one and it was closed as a duplicate of this one!
Comment 32 Marian Mirilovic 2013-04-18 17:02:46 UTC
*** Bug 228718 has been marked as a duplicate of this bug. ***
Comment 33 Marian Mirilovic 2013-04-18 17:03:17 UTC
*** Bug 228681 has been marked as a duplicate of this bug. ***
Comment 34 Marian Mirilovic 2013-04-18 17:04:14 UTC
*** Bug 228713 has been marked as a duplicate of this bug. ***
Comment 35 Sergey Petrov 2013-04-18 19:25:12 UTC
I'm not sure what patch2 means but in my opinion the fix should be ported into 7.3.1
Comment 36 Marian Mirilovic 2013-04-19 08:52:37 UTC
(In reply to comment #35)
> I'm not sure what patch2 means but in my opinion the fix should be ported into
> 7.3.1

Patch 2 = 7.3.1
Comment 37 Marian Mirilovic 2013-04-19 11:03:11 UTC
*** Bug 228757 has been marked as a duplicate of this bug. ***
Comment 38 Marian Mirilovic 2013-04-19 13:15:38 UTC
*** Bug 228724 has been marked as a duplicate of this bug. ***
Comment 39 Marian Mirilovic 2013-04-20 07:41:11 UTC
*** Bug 228668 has been marked as a duplicate of this bug. ***
Comment 40 Tomas Danek 2013-04-23 10:47:41 UTC
Fix does not need to be backported, netbeans.org accepts http connections for required URL again.
Exceptions reporter server is set up and working again, thanks for patience everyone.
Comment 41 Marian Mirilovic 2013-04-25 17:09:26 UTC
*** Bug 228513 has been marked as a duplicate of this bug. ***
Comment 42 Marian Mirilovic 2013-04-25 17:14:35 UTC
*** Bug 225694 has been marked as a duplicate of this bug. ***
Comment 43 Antonin Nebuzelsky 2013-05-21 14:14:48 UTC
As discussed offline, the fix needs to be backported into 7.3.1, for the case iff server goes back to http->https redirects.
Comment 44 Tomas Danek 2013-05-21 14:19:40 UTC
ok, will backport tomorrow. 
(In reply to comment #43)
> As discussed offline, the fix needs to be backported into 7.3.1, for the case
> iff server goes back to http->https redirects.
Comment 45 Tomas Danek 2013-05-22 12:41:00 UTC
backported release73

changeset:   262230:7a4e7770b327
branch:      release73
user:        musilt2@netbeans.org
date:        Thu Apr 11 17:53:52 2013 +0200
summary:     #228156: Cannot report exception since nb.org migration (more robust fix)

changeset:   262231:335be4c1a2a3
branch:      release73
user:        musilt2@netbeans.org
date:        Fri Apr 12 08:03:11 2013 +0200
summary:     #228156: Cannot report exception since nb.org migration (additional fix to make tests passing)

changeset:   262232:ddc6dbdc95a7
branch:      release73
tag:         tip
user:        musilt2@netbeans.org
date:        Wed May 22 14:32:01 2013 +0200
summary:     Increasing spec version for 7.3patch2

Verification appreciated.
Comment 46 Quality Engineering 2013-05-23 00:18:30 UTC
Integrated into 'releases', will be available in build *201305222200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/7a4e7770b327
User: musilt2@netbeans.org
Log: #228156: Cannot report exception since nb.org migration (more robust fix)
Comment 47 Marian Mirilovic 2013-06-07 15:39:00 UTC
verified ... in reality we will see that after another round of migration to https (13/09?)
Comment 48 Marian Mirilovic 2013-07-22 14:57:51 UTC
*** Bug 233028 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo