Bug 227963 - Options => Fonts & Colors - Cannot create or import Profiles
Options => Fonts & Colors - Cannot create or import Profiles
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
7.4
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Theofanis Oikonomou
issues@platform
73patch2-verified
:
: 228893 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-26 17:32 UTC by MrJxN
Modified: 2013-05-17 07:41 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MrJxN 2013-03-26 17:32:04 UTC
NetBeans Dev 201303252300m, Windows 7 64 bit 

Reproducible Steps:

Options => Fonts & Colors
With "NetBeans" Profile selected(*), click Duplicate and enter new profile name "Test"
Change fonts, color settings
Click Apply (or OK)
New Profile deselected, reverts to "Netbeans" Profile
"Test" Profile not available in dropdown list

Restart Netbeans
"Test" Profile now in list(**)
When selected, no customized settings are updated, still using "Netbeans" defaults

Import ZIP file(***) containing fonts and colors settings from previous Netbeans version.  
Restart Netbeans
Profiles displayed in dropdown list, but again, none of the custom settings are changed.  

Notes:  
* Or any of the defaults Profiles provided with installer (all work)
** 1. Duplicated settings DO have a folder at: C:\Users\Owner\AppData\Roaming\NetBeans\dev\config\Editors\FontsColors
2. Imported Settings files DO have folders at:
C:\Users\Owner\AppData\Roaming\NetBeans\dev\config\Editors\text\x-php5\FontsColors
*** This includes settings ZIPs downloaded from third parties and ZIPs of original settings
Comment 1 Jiri Prox 2013-04-04 12:43:34 UTC
Reproducible, 
The new profile disappears when pressing Apply
Comment 2 Milutin Kristofic 2013-04-15 14:31:37 UTC
Fix for creating profiles. http://hg.netbeans.org/jet-main/rev/93a6642aa712
Comment 3 Milutin Kristofic 2013-04-16 15:56:50 UTC
The problem with import, export:

There was a change in import and export Bug #226998. After this change, when you import font&colors the following exception is thrown. It hits first file and rest of files are not coppied. I am sending this for evaluation in recent changes.

Caused: java.io.SyncFailedException: File .nbattrs already exists in filesystem /home/mito/nb/develop/nbbuild/testuserdir/config (/home/mito/nb/develop/nbbuild/testuserdir/config/.nbattrs).
	at org.openide.filesystems.LocalFileSystem.createData(LocalFileSystem.java:279)
	at org.openide.filesystems.LocalFileSystem$Impl.createData(LocalFileSystem.java:588)
	at org.openide.filesystems.AbstractFileObject.createData(AbstractFileObject.java:474)
	at org.openide.filesystems.FileUtil.createData(FileUtil.java:783)
	at org.openide.filesystems.MultiFileObject.createData(MultiFileObject.java:1189)
	at org.openide.filesystems.FileUtil.createData(FileUtil.java:783)
	at org.openide.filesystems.MultiFileObject.createData(MultiFileObject.java:1189)
	at org.openide.filesystems.FileUtil.createData(FileUtil.java:783)
	at org.netbeans.modules.options.export.OptionsExportModel.createOutputStream(OptionsExportModel.java:1062)
	at org.netbeans.modules.options.export.OptionsExportModel.copyFile(OptionsExportModel.java:831)
	at org.netbeans.modules.options.export.OptionsExportModel.copyZipFile(OptionsExportModel.java:615)
[catch] at org.netbeans.modules.options.export.OptionsExportModel.copyFiles(OptionsExportModel.java:592)
	at org.netbeans.modules.options.export.OptionsExportModel.doImport(OptionsExportModel.java:176)
	at org.netbeans.modules.options.export.OptionsChooserPanel.showImportDialog(OptionsChooserPanel.java:286)
	at org.netbeans.modules.options.OptionsDisplayerImpl$4.actionPerformed(OptionsDisplayerImpl.java:266)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.Component.processMouseEvent(Component.java:6505)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
	at java.awt.Component.processEvent(Component.java:6270)
	at java.awt.Container.processEvent(Container.java:2229)
	at java.awt.Component.dispatchEventImpl(Component.java:4861)
	at java.awt.Container.dispatchEventImpl(Container.java:2287)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
	at java.awt.Container.dispatchEventImpl(Container.java:2273)
	at java.awt.Window.dispatchEventImpl(Window.java:2719)
	at java.awt.Component.dispatchEvent(Component.java:4687)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
	at java.awt.EventQueue.access$200(EventQueue.java:103)
	at java.awt.EventQueue$3.run(EventQueue.java:688)
	at java.awt.EventQueue$3.run(EventQueue.java:686)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
	at java.awt.EventQueue$4.run(EventQueue.java:702)
	at java.awt.EventQueue$4.run(EventQueue.java:700)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Comment 4 Quality Engineering 2013-04-18 02:21:43 UTC
Integrated into 'main-golden', will be available in build *201304172301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/93a6642aa712
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #227963 - Options => Fonts & Colors - Cannot create or import Profiles
Comment 5 Jiri Prox 2013-04-23 13:30:36 UTC
*** Bug 228893 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Prox 2013-04-23 13:31:38 UTC
Importing setting is blocked, no easy workaround -> P2
Comment 7 Theofanis Oikonomou 2013-05-06 14:29:44 UTC
Fixed exceptions thrown during import: http://hg.netbeans.org/core-main/rev/cd31c74cd99b
Comment 8 Quality Engineering 2013-05-07 02:25:59 UTC
Integrated into 'main-golden', will be available in build *201305062300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cd31c74cd99b
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: #227963 - Options => Fonts & Colors - Cannot create or import Profiles
Comment 9 Tomas Danek 2013-05-10 12:23:35 UTC
verified in trunk. Please backport to 7.3.1 (as issue #226998 is backported as well)
Comment 10 Theofanis Oikonomou 2013-05-10 12:58:13 UTC
backported to release73: http://hg.netbeans.org/releases/rev/4fd2c3017226
Comment 11 Quality Engineering 2013-05-11 00:17:16 UTC
Integrated into 'releases', will be available in build *201305102200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/4fd2c3017226
User: Theofanis Oikonomou <theofanis@netbeans.org>
Log: #227963 - Options => Fonts & Colors - Cannot create or import Profiles
(transplanted from cd31c74cd99b02b0b38561294fc97d1cf9c8ab55)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo