Bug 227957 - FileUtil.refreshAll after Ant build
FileUtil.refreshAll after Ant build
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant
7.3
PC Solaris
: P4 (vote)
: TBD
Assigned To: Tomas Stupka
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-26 15:50 UTC by Egor Ushakov
Modified: 2016-07-07 08:36 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
several thread dumps right after build (188.69 KB, text/plain)
2013-04-01 08:39 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Egor Ushakov 2013-03-26 15:50:58 UTC
Even though I disabled Source auto-scanning in options/misc/files I see it happen every time I build a project (huge cpu load and system is slow for some time), in stack trace - refresh recursive listeners...
Comment 1 Tomas Zezula 2013-03-27 11:53:30 UTC
Egor,
can you please attach the stack trace.
Thanks!
Comment 2 Egor Ushakov 2013-04-01 08:39:13 UTC
Created attachment 133243 [details]
several thread dumps right after build

I was mistaken about recursive listeners, it is FileUtil.refreshAll
Comment 3 Jaroslav Tulach 2013-07-23 10:37:32 UTC
org.apache.tools.ant.module.bridge.impl.BridgeImpl requested refreshAll, so filesystems are doing refresh all. Is it a problem? On all systems or on Solaris only (I suspect you don't have native listeners on Solaris turned on).

Anyway the only Ant support can stop requesting refreshAll. Passing to Ant.
Comment 4 Egor Ushakov 2013-07-23 11:53:05 UTC
I saw that on Solaris with disabled sources auto-scanning, so I guess the bug is that BridgeImpl does not honor "sources auto-scanning" setting. On a system without native listeners every call to refreshAll may produce huge load on filesystem and slow everything the IDE down for several minutes.
Comment 5 Milos Kleint 2013-07-23 11:57:23 UTC
(In reply to comment #4)
> I saw that on Solaris with disabled sources auto-scanning, so I guess the bug
> is that BridgeImpl does not honor "sources auto-scanning" setting. On a system
> without native listeners every call to refreshAll may produce huge load on
> filesystem and slow everything the IDE down for several minutes.

sources auto-scanning is likely unrelated to the filesystem level calls. If it is, it should be handled on the filesystem's internals side, not on the API client side (ant) - back to P4, I don't see the reason above as justified to increase priority
Comment 6 Martin Balin 2016-07-07 08:36:54 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo