Bug 227866 - AssertionError: childName: C:\Users\OwnerH\Documents\NetBeansProjects\SMS\nbproject folderName: C:\Users\OwnerH\Documents\NetBeansProjects\sms
AssertionError: childName: C:\Users\OwnerH\Documents\NetBeansProjects\SMS\nbp...
Status: RESOLVED INVALID
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-24 16:06 UTC by imad_aqra
Modified: 2013-07-23 10:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (8.12 KB, text/plain)
2013-03-24 16:06 UTC, imad_aqra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description imad_aqra 2013-03-24 16:06:56 UTC
This bug was originally marked as duplicate of bug 161960, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) Client VM, 21.0-b17, Java(TM) SE Runtime Environment, 1.7.0-b147
OS: Windows 7

User Comments:
diesil: renaming project




Stacktrace: 
java.lang.AssertionError: childName: C:\Users\OwnerH\Documents\NetBeansProjects\SMS\nbproject folderName: C:\Users\OwnerH\Documents\NetBeansProjects\sms
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.addChild(ChildrenSupport.java:135)
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.rescanChild(ChildrenSupport.java:193)
   at org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.getChild(ChildrenSupport.java:108)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj$FolderChildrenCache.getChild(FolderObj.java:682)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj.createFolderImpl(FolderObj.java:259)
   at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FolderObj$2.call(FolderObj.java:319)
Comment 1 imad_aqra 2013-03-24 16:06:58 UTC
Created attachment 132994 [details]
stacktrace
Comment 2 Jaroslav Tulach 2013-07-23 10:29:45 UTC
Seems like a clash between
org.netbeans.modules.autosave.command.AutoSaveController(:123)
and regular save action:
org.openide.actions.SaveAction.performAction

Filesystem API properly throws an exception in case two threads try to obtain output stream for the same file object. From the point of view of filesystem API, this is not a bug - marking invalid.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo