Bug 227665 - org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO: LowPerformance took 24099 ms.
org.netbeans.modules.masterfs.filebasedfs.utils.FileChangedManager.priorityIO...
Status: RESOLVED WONTFIX
Product: guibuilder
Classification: Unclassified
Component: Code
7.3
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-19 17:30 UTC by Exceptions Reporter
Modified: 2013-08-16 10:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (21.42 KB, application/nps)
2013-03-19 17:30 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-03-19 17:30:53 UTC
This bug was originally marked as duplicate of bug 219038, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) Client VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_15-b03
OS: Linux

User Comments:
GUEST: editing gui



Maximum slowness yet reported was 24099 ms, average is 24099
Comment 1 Exceptions Reporter 2013-03-19 17:30:55 UTC
Created attachment 132794 [details]
nps snapshot
Comment 2 Jaroslav Havlin 2013-08-16 10:15:12 UTC
Method o.n.m.form.JavaCodeGenerator$FormListener.formChanged() performs some operation (in EDT) that requires class loading.
(org.netbeans.api.java.source.TreeUtilities.ensureCommentsMapped()).

This probably cannot be fixed. It seems that the system was under heavy load.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo