Bug 227639 - org.openide.filesystems.LocalFileSystem.lastModified: LowPerformance took 20646 ms.
org.openide.filesystems.LocalFileSystem.lastModified: LowPerformance took 206...
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
7.3
All All
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-18 18:03 UTC by Exceptions Reporter
Modified: 2013-08-16 10:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (128.10 KB, application/nps)
2013-03-18 18:04 UTC, Exceptions Reporter
Details
nps snapshot (102.31 KB, application/nps)
2013-05-16 11:40 UTC, deep_pl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-03-18 18:03:58 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) Client VM, 22.1-b02, Java(TM) SE Runtime Environment, 1.7.0_03-b05
OS: Windows 7

User Comments:
GUEST: updating from svn



Maximum slowness yet reported was 56813 ms, average is 38729
Comment 1 Exceptions Reporter 2013-03-18 18:04:02 UTC
Created attachment 132769 [details]
nps snapshot
Comment 2 deep_pl 2013-05-16 11:40:59 UTC
Created attachment 134512 [details]
nps snapshot

hdd go creazy..
Comment 3 Jaroslav Havlin 2013-08-16 10:28:28 UTC
Slowness while opening a TopComponent, caused by
o.n.core.windows.persistence.PersistenceManager.createTopComponentPersistentID().

All reports come from OS Windows, so it seems that the main problem was slow filesystem. I suppose that the data were read only from userdir.
This cannot fixed in NetBeans.

Thanks for reporting.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo