Bug 227511 - AssertionError at com.sun.tools.javac.util.Assert.error
AssertionError at com.sun.tools.javac.util.Assert.error
Status: NEW
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P3 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-15 10:09 UTC by lucabur
Modified: 2013-05-21 15:41 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.54 KB, text/plain)
2013-03-15 10:09 UTC, lucabur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lucabur 2013-03-15 10:09:56 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_13-b20
OS: Windows 7

User Comments:
lucabur: Just opening the IDE




Stacktrace: 
java.lang.AssertionError
   at com.sun.tools.javac.util.Assert.error(Assert.java:126)
   at com.sun.tools.javac.util.Assert.checkNonNull(Assert.java:61)
   at com.sun.tools.javac.comp.Lower.checkAccessConstructorTags(Lower.java:713)
   at com.sun.tools.javac.comp.Lower.translateTopLevelClass(Lower.java:3692)
   at com.sun.tools.javac.main.JavaCompiler.desugar(JavaCompiler.java:1430)
   at com.sun.tools.javac.main.JavaCompiler.desugar(JavaCompiler.java:1302)
Comment 1 lucabur 2013-03-15 10:09:58 UTC
Created attachment 132638 [details]
stacktrace
Comment 2 lucabur 2013-05-21 15:41:06 UTC
May or not be related but I have frequent log messages like this;
-
WARNING [org.netbeans.modules.java.source.tasklist.IncorrectErrorBadges]: Incorrect error badges detected, file=C:\JavaProjects\hermes\test\it\sv\hermes\invoice\service\impl\BaseInvoiceProcessorTest.java.
WARNING [org.netbeans.modules.java.source.tasklist.IncorrectErrorBadges]: Not PathRegistry controlled root: C:\JavaProjects\Hermes\test@a97cc55c:60e11314
_
and the source of the involved java file (BaseInvoiceProcessorTest.java in this case) becames spotted of red lines with unresolved symbol errors or other errors
This behaviour happened just after the upgrade to NB 7.3
It is not clear to me how to bypass ... sometime deleting the NB cache helps, sometime doesn't


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo