Bug 227350 - Warn user that GlassFish 4 does not run with JDK6
Warn user that GlassFish 4 does not run with JDK6
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
7.3.1
All All
: P1 (vote)
: 7.3.1
Assigned To: TomasKraus
issues@serverplugins
73patch2-verified
:
Depends on:
Blocks: 227371
  Show dependency treegraph
 
Reported: 2013-03-12 10:41 UTC by Jiri Skrivanek
Modified: 2013-05-09 13:29 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Java selection. (18.58 KB, image/png)
2013-03-19 08:33 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2013-03-12 10:41:17 UTC
User should be warned that GlassFish 4 doesn't run with JDK6. Otherwise there is only a message in console log and server is in waiting mode until timeout expires. Ideally when user invokes Start action a warning should appear and window with Java executable setting should be offered.
Comment 1 TomasKraus 2013-03-12 16:19:54 UTC
User can configure Java executable in Properties. I was not planning to do any changes in this for 7.3.1. But I would like to completely redesign both registration wizard and server properties in next major release.

But OK. I'll create some popup window to warn user and allow him to select JDK 6+ for GF3 and 7+ for GF4 (from those registered in NB).

Marking this as P1 RFE, it's not defect in existing functionality but something is missing here. Targeting for 7.3.1.
Comment 2 TomasKraus 2013-03-15 14:45:42 UTC
Checked into web-main:
----------------------
changeset:   247930:d10c3e9f86d0
branch:      javaee7
summary:     #227350 - Warn user that GlassFish was started with
             unsupported JDK. Properties editor now works with
             NetBeans Java SE platforms.

TODO: Trunk merge which can make some conflicts.
Comment 3 Jiri Skrivanek 2013-03-18 08:39:45 UTC
I have few comments:

- title of warning dialog is "Message"
- missing Cancel button in this dialog (for example if you have just JDK6 and combo box states "None" then when you close this dialog with Escape button it starts Java DB)
- both the warning dialog and Java panel in properties should have button to open Java Platform Manager
- design of Java panel in properties is not accurate on Windows (components should have variable width) - see screen shot
- I added bug 227600 to update help
Comment 4 TomasKraus 2013-03-18 15:49:20 UTC
Done on both javaee7 and trunk.
Comment 5 Jiri Skrivanek 2013-03-19 08:33:30 UTC
Created attachment 132782 [details]
Java selection.

It is better now. Just minor comments:

- "Java SE Platform" dialog not properly formatted on Windows (see screen shot) - labels "Java SE JDK" and "Update server properties:" not aligned with combo box resp. check box
- information "GlassFish Server Server can't start...." is redundant IMO - if I click Cancel I do not expect it will start; OK button should be disabled if combo box is empty
Comment 6 Quality Engineering 2013-03-23 01:57:28 UTC
Integrated into 'main-golden', will be available in build *201303222300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d10c3e9f86d0
User: Tomas Kraus <TomasKraus@netbeans.org>
Log: #227350 - Warn user that GlassFish was started with unsupported JDK. Properties editor now works with NetBeans Java SE platforms.
Comment 7 Jiri Skrivanek 2013-03-25 11:22:54 UTC
Verified but it seems that this is becoming obsolete because only JDK 7 will be supported.
Comment 8 Marian Mirilovic 2013-05-03 11:15:24 UTC
So, where exactly is this issue fixed ? Is it already in release73 repository ?
If so, please change SW to '73patch2-fixed',
If not, please backport the fix into release73 ASAP 

Thanks in advance.
Comment 9 TomasKraus 2013-05-03 18:38:13 UTC
I'm on vacation and I can't do much from here. But all javaee7 changesets are logged in the bug so you can verify if they are in release73 too.
Comment 10 Marian Mirilovic 2013-05-04 12:25:18 UTC
(In reply to comment #9)
> I'm on vacation and I can't do much from here. But all javaee7 changesets are
> logged in the bug so you can verify if they are in release73 too.

No Tomas, I am not supposed to do so. We are following clear rules for integrations into release73 branch, so please check whether the changeset is already in release73 repository and let us know !!!

BTW: http://hg.netbeans.org/releases/log?rev=d10c3e9f86d0 ... is it or it isn't already fixed in release73 ?
Comment 11 Jiri Rechtacek 2013-05-06 08:33:51 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > I'm on vacation and I can't do much from here. But all javaee7 changesets are
> > logged in the bug so you can verify if they are in release73 too.
> 
> No Tomas, I am not supposed to do so. We are following clear rules for
> integrations into release73 branch, so please check whether the changeset is
> already in release73 repository and let us know !!!
> 
> BTW: http://hg.netbeans.org/releases/log?rev=d10c3e9f86d0 ... is it or it isn't
> already fixed in release73 ?

Yes, it's. I can confirm the fix is part of release73 branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo