Bug 22734 - Conflict between RP and AWT thread during IDE start
Conflict between RP and AWT thread during IDE start
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: treefs
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Jaroslav Tulach
issues@obsolete
: THREAD
: 28415 33774 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-24 10:32 UTC by _ rkubacki
Modified: 2003-06-06 16:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (10.65 KB, text/plain)
2002-04-24 10:32 UTC, _ rkubacki
Details
Another thread dump (7.83 KB, text/plain)
2002-05-28 12:47 UTC, _ rkubacki
Details
The thread dump when the IDE locked during a work. (23.15 KB, text/plain)
2002-08-03 16:08 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ rkubacki 2002-04-24 10:32:03 UTC
Sometimes IDE doesn't start. Thread dump will be
attached.
Comment 1 _ rkubacki 2002-04-24 10:32:34 UTC
Created attachment 5535 [details]
thread dump
Comment 2 Jaroslav Tulach 2002-04-25 11:52:22 UTC
treefs is not remotefs!
Comment 3 _ rkubacki 2002-05-28 12:47:44 UTC
Created attachment 5984 [details]
Another thread dump
Comment 4 _ rkubacki 2002-05-28 12:52:32 UTC
Now I can reproduce it when switching projects. Raising priority.
Comment 5 Martin Entlicher 2002-08-03 16:06:32 UTC
Please fix this issue soon. It happened to me several times during
work. It seems, that it should be enough not to run RepManager in the
default RequestProcessor. Please use RequestProcessor.getDefault() or
a custom RequestProcessor.
Comment 6 Martin Entlicher 2002-08-03 16:08:14 UTC
Created attachment 7005 [details]
The thread dump when the IDE locked during a work.
Comment 7 Jaroslav Tulach 2002-08-28 10:21:57 UTC
RepManager.java
new revision: 1.2
Comment 8 Jaroslav Tulach 2002-11-26 18:26:19 UTC
*** Issue 28415 has been marked as a duplicate of this issue. ***
Comment 9 Jaroslav Tulach 2003-06-06 16:00:35 UTC
*** Issue 33774 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo