Bug 227187 - NullPointerException at org.netbeans.modules.openfile.OpenFileAction.actionPerformed
NullPointerException at org.netbeans.modules.openfile.OpenFileAction.actionPe...
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Code
7.3
All All
: P1 (vote)
: 7.3.1
Assigned To: Jaroslav Havlin
issues@utilities
EXCEPTIONS_REPORT, 73patch2-fixed
:
: 228195 228236 229331 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-07 21:57 UTC by tomjnsn
Modified: 2013-05-27 23:33 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.57 KB, text/plain)
2013-03-07 21:57 UTC, tomjnsn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomjnsn 2013-03-07 21:57:36 UTC
Build: NetBeans IDE Dev (Build 201303052300)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_10-b18
OS: Mac OS X

Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.openfile.OpenFileAction.actionPerformed(OpenFileAction.java:197)
   at org.openide.awt.AlwaysEnabledAction$1.run(AlwaysEnabledAction.java:198)
   at org.openide.util.actions.ActionInvoker$1.run(ActionInvoker.java:95)
   at org.openide.util.actions.ActionInvoker.doPerformAction(ActionInvoker.java:116)
   at org.openide.util.actions.ActionInvoker.invokeAction(ActionInvoker.java:99)
   at org.openide.awt.AlwaysEnabledAction.actionPerformed(AlwaysEnabledAction.java:201)
Comment 1 tomjnsn 2013-03-07 21:57:37 UTC
Created attachment 132356 [details]
stacktrace
Comment 2 Jaroslav Havlin 2013-03-08 12:54:56 UTC
http://hg.netbeans.org/core-main/rev/bd33bb9720cf
Fixed.
Thanks for reporting.
Comment 3 Quality Engineering 2013-03-09 01:57:15 UTC
Integrated into 'main-golden', will be available in build *201303082300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bd33bb9720cf
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #227187: NPE at o.n.m.openfile.OpenFileAction.actionPerformed
Comment 4 Stanislav Aubrecht 2013-04-03 13:59:49 UTC
*** Bug 228195 has been marked as a duplicate of this bug. ***
Comment 5 Marian Mirilovic 2013-04-25 17:49:08 UTC
*** Bug 228236 has been marked as a duplicate of this bug. ***
Comment 6 Marian Mirilovic 2013-05-07 06:26:12 UTC
*** Bug 229331 has been marked as a duplicate of this bug. ***
Comment 7 Ralph Ruijs 2013-05-24 10:11:27 UTC
I ran into this bug yesterday when using 7.3.1 rc. Looking at the exception reports this bug was already there in 7.3. I think this is something we do want to have fixed for 7.3.1.
Comment 8 Ondrej Vrabec 2013-05-27 14:51:11 UTC
the fix is fine
Comment 9 Jaroslav Havlin 2013-05-27 15:19:33 UTC
Integrated into release73 as:
http://hg.netbeans.org/releases/rev/3ce3df36d245 ("transplanted" patch)
http://hg.netbeans.org/releases/rev/2ebd32fb41a7 (increased spec. version)
Comment 10 Quality Engineering 2013-05-27 23:33:57 UTC
Integrated into 'releases', will be available in build *201305272201* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/3ce3df36d245
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #227187: NPE at o.n.m.openfile.OpenFileAction.actionPerformed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo