Bug 227165 - NullPointerException at javax.swing.SizeRequirements.calculateAlignedPositions
NullPointerException at javax.swing.SizeRequirements.calculateAlignedPositions
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: JDK Problems
7.4
All All
: P3 (vote)
: TBD
Assigned To: Antonin Nebuzelsky
issues@platform
EXCEPTIONS_REPORT
:
: 227180 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-07 12:42 UTC by misterm
Modified: 2013-06-27 14:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.91 KB, text/plain)
2013-03-07 12:42 UTC, misterm
Details
stacktrace (1.91 KB, text/plain)
2013-03-07 19:21 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description misterm 2013-03-07 12:42:33 UTC
Build: NetBeans IDE Dev (Build 20130307-9c044e516e64)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

Stacktrace: 
java.lang.NullPointerException
   at javax.swing.SizeRequirements.calculateAlignedPositions(SizeRequirements.java:461)
   at javax.swing.BoxLayout.layoutContainer(BoxLayout.java:434)
   at java.awt.Container.layout(Container.java:1503)
   at java.awt.Container.doLayout(Container.java:1492)
   at java.awt.Container.validateTree(Container.java:1688)
   at java.awt.Container.validateTree(Container.java:1697)
Comment 1 misterm 2013-03-07 12:42:36 UTC
Created attachment 132334 [details]
stacktrace
Comment 2 misterm 2013-03-07 19:21:24 UTC
Created attachment 132350 [details]
stacktrace
Comment 3 Marian Mirilovic 2013-03-08 16:02:17 UTC
*** Bug 227180 has been marked as a duplicate of this bug. ***
Comment 4 Antonin Nebuzelsky 2013-06-27 14:20:22 UTC
All the duplicate reports are from the same build run on the same day. Is this exception happening since then?

If still reproducible, can you please evaluate which UI component is causing the exception? And any other information how to reproduce the problem?

Without more information it is impossible to guess the culprit on NB side, or file a bug against JDK (a general issue about NPE in BoxLayout is not going to fly).

Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo